%global _empty_manifest_terminate_build 0
Name:		python-sqlalchemy-jdbcapi
Version:	1.2.2
Release:	1
Summary:	Python SQLAlchemy Dialect for JDBCAPI.
License:	Apache
URL:		https://github.com/daneshpatel/sqlalchemy-jdbcapi
Source0:	https://mirrors.aliyun.com/pypi/web/packages/4f/07/6477cfb3b16c0abea0f2ecb815a40f29502a8302bd98f6f68321e4059efd/sqlalchemy_jdbcapi-1.2.2.tar.gz
BuildArch:	noarch

Requires:	python3-SQLAlchemy
Requires:	python3-JayDeBeApi

%description
The primary purpose of this dialect is to provide JDBC connection using provided driver(JAR).

%package -n python3-sqlalchemy-jdbcapi
Summary:	Python SQLAlchemy Dialect for JDBCAPI.
Provides:	python-sqlalchemy-jdbcapi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sqlalchemy-jdbcapi
The primary purpose of this dialect is to provide JDBC connection using provided driver(JAR).

%package help
Summary:	Development documents and examples for sqlalchemy-jdbcapi
Provides:	python3-sqlalchemy-jdbcapi-doc
%description help
The primary purpose of this dialect is to provide JDBC connection using provided driver(JAR).

%prep
%autosetup -n sqlalchemy_jdbcapi-1.2.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sqlalchemy-jdbcapi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
- Package Spec generated