%global _empty_manifest_terminate_build 0
Name: python-springlabs-django
Version: 0.3.5
Release: 1
Summary: Springlabs Projects Django Standard
License: MIT License
URL: https://springlabs.ai/
Source0: https://mirrors.aliyun.com/pypi/web/packages/ce/84/777aa4d29a19cce80f5c0d727b27beb4b1a5640c8403a3a3643210103a89/springlabs_django-0.3.5.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-requests
%description
MIT
[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
[Django]:
[DjangoRestFramework]:
[Graphene-Django]:
[Python]:
%package -n python3-springlabs-django
Summary: Springlabs Projects Django Standard
Provides: python-springlabs-django
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-springlabs-django
MIT
[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
[Django]:
[DjangoRestFramework]:
[Graphene-Django]:
[Python]:
%package help
Summary: Development documents and examples for springlabs-django
Provides: python3-springlabs-django-doc
%description help
MIT
[//]: # (These are reference links used in the body of this note and get stripped out when the markdown processor does its job. There is no need to format nicely because it shouldn't be seen. Thanks SO - http://stackoverflow.com/questions/4823468/store-comments-in-markdown-syntax)
[Django]:
[DjangoRestFramework]:
[Graphene-Django]:
[Python]:
%prep
%autosetup -n springlabs_django-0.3.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-springlabs-django -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.3.5-1
- Package Spec generated