%global _empty_manifest_terminate_build 0 Name: python-aiopokeapi Version: 0.1.5.1 Release: 1 Summary: An asynchronous API wrapper for the pokeapi. License: MIT URL: https://pypi.org/project/aiopokeapi/ Source0: https://mirrors.aliyun.com/pypi/web/packages/cb/92/739bfa332a911549fea78f7d1a9296c8e748939d8eb60530919b4efad47f/aiopokeapi-0.1.5.1.tar.gz BuildArch: noarch Requires: python3-aiofiles Requires: python3-aiohttp Requires: python3-pytest Requires: python3-pytest-cov Requires: python3-mypy Requires: python3-flake8 Requires: python3-tox %description

AioPokéApi

An Asynchronous API wrapper for the PokéApi.

Report issue · Request feature · Fork project

## 🗝️ Key Features - Use of modern Python keywords: `async` and `await`. - Every object is fully type hinted. - Objects get cached, this increases speed and avoids unnecessary API requests. ## 🌍 Documentation AioPokéApi has a very minimal website, which you can find [here](https://beastmatser.github.io/aiopoke/). It also has some [documentation](https://beastmatser.github.io/aiopoke/docs/). ## ☄️ Installation ```sh pip install aiopokeapi ```
⚙️ Didn't work? Depending on your Python installation, you might need to use one of the following: - Python is not in PATH ```sh path/to/python.exe -m pip install aiopokeapi ``` - Python is in PATH but pip is not ```sh python -m pip install aiopokeapi ``` - Unix systems can use pip3/python3 commands ```sh pip3 install aiopokeapi ``` ```sh python3 -m pip install aiopokeapi ``` - Using multiple Python versions ```sh py -m pip install aiopokeapi ```
## 🚀 Getting started Aiopoke's goal is to be simple and easy to use: ```py import asyncio import aiopoke async def main(): client = aiopoke.AiopokeClient() ability = await client.get_ability(1) generation = await ability.generation.fetch() await client.close() asyncio.run(main()) ``` Or even better, using a context manager: ```py # in main() async with aiopoke.AiopokeClient() as client: ability = await client.get_ability(1) generation = await ability.generation.fetch() ``` %package -n python3-aiopokeapi Summary: An asynchronous API wrapper for the pokeapi. Provides: python-aiopokeapi BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-aiopokeapi

AioPokéApi

An Asynchronous API wrapper for the PokéApi.

Report issue · Request feature · Fork project

## 🗝️ Key Features - Use of modern Python keywords: `async` and `await`. - Every object is fully type hinted. - Objects get cached, this increases speed and avoids unnecessary API requests. ## 🌍 Documentation AioPokéApi has a very minimal website, which you can find [here](https://beastmatser.github.io/aiopoke/). It also has some [documentation](https://beastmatser.github.io/aiopoke/docs/). ## ☄️ Installation ```sh pip install aiopokeapi ```
⚙️ Didn't work? Depending on your Python installation, you might need to use one of the following: - Python is not in PATH ```sh path/to/python.exe -m pip install aiopokeapi ``` - Python is in PATH but pip is not ```sh python -m pip install aiopokeapi ``` - Unix systems can use pip3/python3 commands ```sh pip3 install aiopokeapi ``` ```sh python3 -m pip install aiopokeapi ``` - Using multiple Python versions ```sh py -m pip install aiopokeapi ```
## 🚀 Getting started Aiopoke's goal is to be simple and easy to use: ```py import asyncio import aiopoke async def main(): client = aiopoke.AiopokeClient() ability = await client.get_ability(1) generation = await ability.generation.fetch() await client.close() asyncio.run(main()) ``` Or even better, using a context manager: ```py # in main() async with aiopoke.AiopokeClient() as client: ability = await client.get_ability(1) generation = await ability.generation.fetch() ``` %package help Summary: Development documents and examples for aiopokeapi Provides: python3-aiopokeapi-doc %description help

AioPokéApi

An Asynchronous API wrapper for the PokéApi.

Report issue · Request feature · Fork project

## 🗝️ Key Features - Use of modern Python keywords: `async` and `await`. - Every object is fully type hinted. - Objects get cached, this increases speed and avoids unnecessary API requests. ## 🌍 Documentation AioPokéApi has a very minimal website, which you can find [here](https://beastmatser.github.io/aiopoke/). It also has some [documentation](https://beastmatser.github.io/aiopoke/docs/). ## ☄️ Installation ```sh pip install aiopokeapi ```
⚙️ Didn't work? Depending on your Python installation, you might need to use one of the following: - Python is not in PATH ```sh path/to/python.exe -m pip install aiopokeapi ``` - Python is in PATH but pip is not ```sh python -m pip install aiopokeapi ``` - Unix systems can use pip3/python3 commands ```sh pip3 install aiopokeapi ``` ```sh python3 -m pip install aiopokeapi ``` - Using multiple Python versions ```sh py -m pip install aiopokeapi ```
## 🚀 Getting started Aiopoke's goal is to be simple and easy to use: ```py import asyncio import aiopoke async def main(): client = aiopoke.AiopokeClient() ability = await client.get_ability(1) generation = await ability.generation.fetch() await client.close() asyncio.run(main()) ``` Or even better, using a context manager: ```py # in main() async with aiopoke.AiopokeClient() as client: ability = await client.get_ability(1) generation = await ability.generation.fetch() ``` %prep %autosetup -n aiopokeapi-0.1.5.1 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-aiopokeapi -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 0.1.5.1-1 - Package Spec generated