%global _empty_manifest_terminate_build 0
Name:		python-caribou
Version:	0.3
Release:	1
Summary:	python migrations for sqlite databases
License:	Public Domain
URL:		http://github.com/clutchski/caribou
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b7/9d/e06d2acfe2bd2cfb5ab88d88935492fa0a76c600f628973696e04f7cd9d1/caribou-0.3.0.tar.gz
BuildArch:	noarch


%description
Caribou is a simple SQLite database migrations library, built primarily
to manage the evoluton of client side databases over multiple releases 
of an application.




%package -n python3-caribou
Summary:	python migrations for sqlite databases
Provides:	python-caribou
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-caribou
Caribou is a simple SQLite database migrations library, built primarily
to manage the evoluton of client side databases over multiple releases 
of an application.




%package help
Summary:	Development documents and examples for caribou
Provides:	python3-caribou-doc
%description help
Caribou is a simple SQLite database migrations library, built primarily
to manage the evoluton of client side databases over multiple releases 
of an application.




%prep
%autosetup -n caribou-0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-caribou -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Wed Mar 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3-1
- Package Spec generated