%global _empty_manifest_terminate_build 0
Name: python-chaospy
Version: 4.3.10
Release: 1
Summary: Numerical tool for performing uncertainty quantification
License: MIT license
URL: https://pypi.org/project/chaospy/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/53/1a/2afb10b9ad97588201a75a88bdf4dd52dae0f17fb69ea27eb930555e15d3/chaospy-4.3.10.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-numpoly
Requires: python3-scipy
Requires: python3-setuptools
Requires: python3-openturns
Requires: python3-scikit-learn
Requires: python3-gstools
Requires: python3-jupyter
Requires: python3-matplotlib
Requires: python3-nbsphinx
Requires: python3-sphinxcontrib-bibtex
Requires: python3-black
Requires: python3-pylint
Requires: python3-pydocstyle
Requires: python3-pydata-sphinx-theme
Requires: python3-sympy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-codecov
Requires: python3-coverage
Requires: python3-Sphinx
Requires: python3-sphinx-automodapi
Requires: python3-build
Requires: python3-twine
%description
Installation should be straight forward from `pip `_:
pip install chaospy
Or if `Conda `_ is more to your liking:
conda install -c conda-forge chaospy
Then go over to the `documentation `_
to see how to use the toolbox.
%package -n python3-chaospy
Summary: Numerical tool for performing uncertainty quantification
Provides: python-chaospy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-chaospy
Installation should be straight forward from `pip `_:
pip install chaospy
Or if `Conda `_ is more to your liking:
conda install -c conda-forge chaospy
Then go over to the `documentation `_
to see how to use the toolbox.
%package help
Summary: Development documents and examples for chaospy
Provides: python3-chaospy-doc
%description help
Installation should be straight forward from `pip `_:
pip install chaospy
Or if `Conda `_ is more to your liking:
conda install -c conda-forge chaospy
Then go over to the `documentation `_
to see how to use the toolbox.
%prep
%autosetup -n chaospy-4.3.10
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-chaospy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Wed Mar 08 2023 Python_Bot - 4.3.10-1
- Package Spec generated