%global _empty_manifest_terminate_build 0
Name:		python-dtopt
Version:	0.1
Release:	1
Summary:	Add options to doctest examples while they are running
License:	MIT
URL:		http://pypi.python.org/pypi/dtopt/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ba/2c/e012086b9f515110a31bbd3e78a509e2b968e0f6808d219c178c5ae697f7/dtopt-0.1.tar.gz
BuildArch:	noarch


%description
When using the `doctest
<http://python.org/doc/current/lib/module-doctest.html>`_ module it is often
convenient to use the ELLIPSIS option, which allows you to use ``...`` as a
wildcard.  But you either have to setup the test runner to use this option, or
you must put ``#doctest: +ELLIPSIS`` on *every* example that uses this feature.

``dtopt`` lets you enable this option globally from within a doctest, by doing::

    >>> from dtopt import ELLIPSIS

(The options ``NORMALIZE_WHITESPACE`` and ``COMPARE`` are also available)

You can install this from `the subversion repository
<http://svn.colorstudy.com/dtopt/trunk/#egg=dtopt-dev>`_ with ``easy_install
dtopt==dev``.

%package -n python3-dtopt
Summary:	Add options to doctest examples while they are running
Provides:	python-dtopt
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dtopt
When using the `doctest
<http://python.org/doc/current/lib/module-doctest.html>`_ module it is often
convenient to use the ELLIPSIS option, which allows you to use ``...`` as a
wildcard.  But you either have to setup the test runner to use this option, or
you must put ``#doctest: +ELLIPSIS`` on *every* example that uses this feature.

``dtopt`` lets you enable this option globally from within a doctest, by doing::

    >>> from dtopt import ELLIPSIS

(The options ``NORMALIZE_WHITESPACE`` and ``COMPARE`` are also available)

You can install this from `the subversion repository
<http://svn.colorstudy.com/dtopt/trunk/#egg=dtopt-dev>`_ with ``easy_install
dtopt==dev``.

%package help
Summary:	Development documents and examples for dtopt
Provides:	python3-dtopt-doc
%description help
When using the `doctest
<http://python.org/doc/current/lib/module-doctest.html>`_ module it is often
convenient to use the ELLIPSIS option, which allows you to use ``...`` as a
wildcard.  But you either have to setup the test runner to use this option, or
you must put ``#doctest: +ELLIPSIS`` on *every* example that uses this feature.

``dtopt`` lets you enable this option globally from within a doctest, by doing::

    >>> from dtopt import ELLIPSIS

(The options ``NORMALIZE_WHITESPACE`` and ``COMPARE`` are also available)

You can install this from `the subversion repository
<http://svn.colorstudy.com/dtopt/trunk/#egg=dtopt-dev>`_ with ``easy_install
dtopt==dev``.

%prep
%autosetup -n dtopt-0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dtopt -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1-1
- Package Spec generated