%global _empty_manifest_terminate_build 0
Name:		python-emcee
Version:	3.1.4
Release:	1
Summary:	The Python ensemble sampling toolkit for MCMC
License:	MIT
URL:		https://emcee.readthedocs.io
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/56/62/f8268fe4cf6f8af3860617a53e935e195ce7406d0b10f3ab0fb85bf17533/emcee-3.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-h5py
Requires:	python3-scipy
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-coverage[toml]

%description
**The Python ensemble sampling toolkit for affine-invariant MCMC**
emcee is a stable, well tested Python implementation of the affine-invariant
ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by
`Goodman & Weare (2010) <http://cims.nyu.edu/~weare/papers/d13.pdf>`_.
The code is open source and has
already been used in several published projects in the Astrophysics
literature.

%package -n python3-emcee
Summary:	The Python ensemble sampling toolkit for MCMC
Provides:	python-emcee
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-emcee
**The Python ensemble sampling toolkit for affine-invariant MCMC**
emcee is a stable, well tested Python implementation of the affine-invariant
ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by
`Goodman & Weare (2010) <http://cims.nyu.edu/~weare/papers/d13.pdf>`_.
The code is open source and has
already been used in several published projects in the Astrophysics
literature.

%package help
Summary:	Development documents and examples for emcee
Provides:	python3-emcee-doc
%description help
**The Python ensemble sampling toolkit for affine-invariant MCMC**
emcee is a stable, well tested Python implementation of the affine-invariant
ensemble sampler for Markov chain Monte Carlo (MCMC)
proposed by
`Goodman & Weare (2010) <http://cims.nyu.edu/~weare/papers/d13.pdf>`_.
The code is open source and has
already been used in several published projects in the Astrophysics
literature.

%prep
%autosetup -n emcee-3.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-emcee -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.4-1
- Package Spec generated