%global _empty_manifest_terminate_build 0
Name: python-fslpy
Version: 3.11.3
Release: 1
Summary: FSL Python library
License: Apache License Version 2.0
URL: https://git.fmrib.ox.ac.uk/fsl/fslpy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/9e/281ba8a9ae7b458bbe8027e717368307d1551a0cabdf3887b11326e7a863/fslpy-3.11.3.tar.gz
BuildArch: noarch
Requires: python3-h5py
Requires: python3-nibabel
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-dill
Requires: python3-indexed-gzip
Requires: python3-wxpython
Requires: python3-trimesh
Requires: python3-rtree
Requires: python3-Pillow
%description
The ``fslpy`` project is a `FSL `_
programming library written in Python. It is used by `FSLeyes
`_.
``fslpy`` is tested against Python versions 3.8, 3.9, 3.10, and 3.11.
%package -n python3-fslpy
Summary: FSL Python library
Provides: python-fslpy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fslpy
The ``fslpy`` project is a `FSL `_
programming library written in Python. It is used by `FSLeyes
`_.
``fslpy`` is tested against Python versions 3.8, 3.9, 3.10, and 3.11.
%package help
Summary: Development documents and examples for fslpy
Provides: python3-fslpy-doc
%description help
The ``fslpy`` project is a `FSL `_
programming library written in Python. It is used by `FSLeyes
`_.
``fslpy`` is tested against Python versions 3.8, 3.9, 3.10, and 3.11.
%prep
%autosetup -n fslpy-3.11.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fslpy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 3.11.3-1
- Package Spec generated