%global _empty_manifest_terminate_build 0
Name:		python-hglib
Version:	2.6.2
Release:	1
Summary:	Mercurial Python library
License:	MIT
URL:		https://bitbucket.org/515k4/hglib/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/87/29/ae7dbf62b0eff6d66adb71a2774a1689184d4bbdbd06ea73d32dd1049eb5/hglib-2.6.2.tar.gz
BuildArch:	noarch


%description
# hglib

The hglib is fork of of [hglib](https://www.mercurial-scm.org/wiki/PythonHglib), which is library with a fast, convenient interface to Mercurial. It uses Mercurial's command server for communication with hg.

Only difference for now is just name of the package and updated tests.

## Basic usage

```python
import hglib

client = hglib.open(path)
log = client.log(revrange="tip")
print(log)
```

## Dependencies ##

* Python 2.7 or 3.5

## Licence ##

MIT

## Contact ##

Michal Siska <michal.515k4@gmail.com>




%package -n python3-hglib
Summary:	Mercurial Python library
Provides:	python-hglib
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-hglib
# hglib

The hglib is fork of of [hglib](https://www.mercurial-scm.org/wiki/PythonHglib), which is library with a fast, convenient interface to Mercurial. It uses Mercurial's command server for communication with hg.

Only difference for now is just name of the package and updated tests.

## Basic usage

```python
import hglib

client = hglib.open(path)
log = client.log(revrange="tip")
print(log)
```

## Dependencies ##

* Python 2.7 or 3.5

## Licence ##

MIT

## Contact ##

Michal Siska <michal.515k4@gmail.com>




%package help
Summary:	Development documents and examples for hglib
Provides:	python3-hglib-doc
%description help
# hglib

The hglib is fork of of [hglib](https://www.mercurial-scm.org/wiki/PythonHglib), which is library with a fast, convenient interface to Mercurial. It uses Mercurial's command server for communication with hg.

Only difference for now is just name of the package and updated tests.

## Basic usage

```python
import hglib

client = hglib.open(path)
log = client.log(revrange="tip")
print(log)
```

## Dependencies ##

* Python 2.7 or 3.5

## Licence ##

MIT

## Contact ##

Michal Siska <michal.515k4@gmail.com>




%prep
%autosetup -n hglib-2.6.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-hglib -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2.6.2-1
- Package Spec generated