%global _empty_manifest_terminate_build 0
Name:		python-nudatus
Version:	0.0.5
Release:	1
Summary:	Strip comments from scripts, intended for use with MicroPython and other storage constrained environments
License:	MIT
URL:		https://github.com/zanderbrown/nudatus
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/23/4d/cf8a2c68ef1f6653e3fb677e35e2fb3c549092853780a0cf6014beb83ec9/nudatus-0.0.5.tar.gz
BuildArch:	noarch

Requires:	python3-black
Requires:	python3-coverage
Requires:	python3-pytest-faulthandler
Requires:	python3-pytest
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-pytest-random-order
Requires:	python3-pytest-cov
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-random-order
Requires:	python3-pytest-faulthandler
Requires:	python3-coverage
Requires:	python3-black
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-pytest-random-order
Requires:	python3-pytest-faulthandler
Requires:	python3-coverage
Requires:	python3-black

%description
Nudatus is a tool to remove comments from Python scripts.
It was created for use in uflash_ to help squeeze longer programs onto the micro:bit but it should be suitable for various environments with restricted storage.
*Note* Nudatus uses the tokenizer built into Python so only supports the syntax of the version it's running on, but it's extremely unlikely this will cause you any issues (print is handled fine).
Personally I pronounce nudatus as new-dat-us which I appreciate is probably 'wrong'.

%package -n python3-nudatus
Summary:	Strip comments from scripts, intended for use with MicroPython and other storage constrained environments
Provides:	python-nudatus
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-nudatus
Nudatus is a tool to remove comments from Python scripts.
It was created for use in uflash_ to help squeeze longer programs onto the micro:bit but it should be suitable for various environments with restricted storage.
*Note* Nudatus uses the tokenizer built into Python so only supports the syntax of the version it's running on, but it's extremely unlikely this will cause you any issues (print is handled fine).
Personally I pronounce nudatus as new-dat-us which I appreciate is probably 'wrong'.

%package help
Summary:	Development documents and examples for nudatus
Provides:	python3-nudatus-doc
%description help
Nudatus is a tool to remove comments from Python scripts.
It was created for use in uflash_ to help squeeze longer programs onto the micro:bit but it should be suitable for various environments with restricted storage.
*Note* Nudatus uses the tokenizer built into Python so only supports the syntax of the version it's running on, but it's extremely unlikely this will cause you any issues (print is handled fine).
Personally I pronounce nudatus as new-dat-us which I appreciate is probably 'wrong'.

%prep
%autosetup -n nudatus-0.0.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-nudatus -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.5-1
- Package Spec generated