%global _empty_manifest_terminate_build 0
Name:		python-pamela
Version:	1.0.0
Release:	1
Summary:	PAM interface using ctypes
License:	MIT
URL:		https://github.com/minrk/pamela
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/48/4d/738e0122a263b6631c7112b3e98566a53afe7d00eefc6355370ec6d9edea/pamela-1.0.0.tar.gz
BuildArch:	noarch


%description
# Pamela: yet another Python wrapper for PAM

There seems to be a glut of Python wrappers for PAM that have since been abandoned.
This repo merges two separate efforts:

- [gnosek/python-pam](https://github.com/gnosek/python-pam)
  - adds wrappers for a few more calls, e.g. opening sessions
  - raises PamError on failure instead of returning False, with informative error messages
- [simplepam](https://github.com/leonnnn/python3-simplepam)
  - adds Python 3 support
  - resets credentials after authentication, apparently for kerberos users

## Why?

Both projects appear to be abandoned, with no response to issues or pull requests in at least a year, and I need it for [JupyterHub](https://github.com/jupyter/jupyterhub).

## Use it

Install:

    pip install pamela

Test:

    python -m pamela -a `whoami`




%package -n python3-pamela
Summary:	PAM interface using ctypes
Provides:	python-pamela
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pamela
# Pamela: yet another Python wrapper for PAM

There seems to be a glut of Python wrappers for PAM that have since been abandoned.
This repo merges two separate efforts:

- [gnosek/python-pam](https://github.com/gnosek/python-pam)
  - adds wrappers for a few more calls, e.g. opening sessions
  - raises PamError on failure instead of returning False, with informative error messages
- [simplepam](https://github.com/leonnnn/python3-simplepam)
  - adds Python 3 support
  - resets credentials after authentication, apparently for kerberos users

## Why?

Both projects appear to be abandoned, with no response to issues or pull requests in at least a year, and I need it for [JupyterHub](https://github.com/jupyter/jupyterhub).

## Use it

Install:

    pip install pamela

Test:

    python -m pamela -a `whoami`




%package help
Summary:	Development documents and examples for pamela
Provides:	python3-pamela-doc
%description help
# Pamela: yet another Python wrapper for PAM

There seems to be a glut of Python wrappers for PAM that have since been abandoned.
This repo merges two separate efforts:

- [gnosek/python-pam](https://github.com/gnosek/python-pam)
  - adds wrappers for a few more calls, e.g. opening sessions
  - raises PamError on failure instead of returning False, with informative error messages
- [simplepam](https://github.com/leonnnn/python3-simplepam)
  - adds Python 3 support
  - resets credentials after authentication, apparently for kerberos users

## Why?

Both projects appear to be abandoned, with no response to issues or pull requests in at least a year, and I need it for [JupyterHub](https://github.com/jupyter/jupyterhub).

## Use it

Install:

    pip install pamela

Test:

    python -m pamela -a `whoami`




%prep
%autosetup -n pamela-1.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pamela -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
- Package Spec generated