%global _empty_manifest_terminate_build 0
Name:		python-posix-ipc
Version:	1.1.1
Release:	1
Summary:	POSIX IPC primitives (semaphores, shared memory and message queues) for Python
License:	http://creativecommons.org/licenses/BSD/
URL:		https://github.com/osvenskan/posix_ipc
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/07/7f/b954f224a226960a4aa98b6c5fa3d4f3fafb20bb8461446e41b563aee863/posix_ipc-1.1.1.tar.gz
BuildArch:	noarch


%description
# POSIX IPC

`posix_ipc` is a Python module (written in C) that permits creation and manipulation of POSIX inter-process semaphores, shared memory and message queues on platforms supporting the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993. This includes nearly all Unices and Windows + Cygwin ≥ 1.7.

`posix_ipc` is compatible with all supported versions of Python 3.

**For complete documentation, see [the usage notes](USAGE.md).**

## Python 2.7 Support

Version 1.0.5 was the last version of `posix_ipc` to support both Python 2.7 and Python 3.x. Starting with version 1.1.0, only Python ≥ 3.6 is supported. No changes (neither fixes nor features) will be backported to 1.0.5.

## Installation

`posix_ipc` is available on PyPI:

	pip install posix-ipc

Or you can clone the project and install it using `setup.py`:

	python setup.py install

## License

`posix_ipc` is free software (free as in speech and free as in beer) released under a 3-clause BSD license. Complete licensing information is available in [the LICENSE file](LICENSE).

## Related

You might also be interested in the similar System V IPC module: https://github.com/osvenskan/sysv_ipc


%package -n python3-posix-ipc
Summary:	POSIX IPC primitives (semaphores, shared memory and message queues) for Python
Provides:	python-posix-ipc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-posix-ipc
# POSIX IPC

`posix_ipc` is a Python module (written in C) that permits creation and manipulation of POSIX inter-process semaphores, shared memory and message queues on platforms supporting the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993. This includes nearly all Unices and Windows + Cygwin ≥ 1.7.

`posix_ipc` is compatible with all supported versions of Python 3.

**For complete documentation, see [the usage notes](USAGE.md).**

## Python 2.7 Support

Version 1.0.5 was the last version of `posix_ipc` to support both Python 2.7 and Python 3.x. Starting with version 1.1.0, only Python ≥ 3.6 is supported. No changes (neither fixes nor features) will be backported to 1.0.5.

## Installation

`posix_ipc` is available on PyPI:

	pip install posix-ipc

Or you can clone the project and install it using `setup.py`:

	python setup.py install

## License

`posix_ipc` is free software (free as in speech and free as in beer) released under a 3-clause BSD license. Complete licensing information is available in [the LICENSE file](LICENSE).

## Related

You might also be interested in the similar System V IPC module: https://github.com/osvenskan/sysv_ipc


%package help
Summary:	Development documents and examples for posix-ipc
Provides:	python3-posix-ipc-doc
%description help
# POSIX IPC

`posix_ipc` is a Python module (written in C) that permits creation and manipulation of POSIX inter-process semaphores, shared memory and message queues on platforms supporting the POSIX Realtime Extensions a.k.a. POSIX 1003.1b-1993. This includes nearly all Unices and Windows + Cygwin ≥ 1.7.

`posix_ipc` is compatible with all supported versions of Python 3.

**For complete documentation, see [the usage notes](USAGE.md).**

## Python 2.7 Support

Version 1.0.5 was the last version of `posix_ipc` to support both Python 2.7 and Python 3.x. Starting with version 1.1.0, only Python ≥ 3.6 is supported. No changes (neither fixes nor features) will be backported to 1.0.5.

## Installation

`posix_ipc` is available on PyPI:

	pip install posix-ipc

Or you can clone the project and install it using `setup.py`:

	python setup.py install

## License

`posix_ipc` is free software (free as in speech and free as in beer) released under a 3-clause BSD license. Complete licensing information is available in [the LICENSE file](LICENSE).

## Related

You might also be interested in the similar System V IPC module: https://github.com/osvenskan/sysv_ipc


%prep
%autosetup -n posix-ipc-1.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-posix-ipc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
- Package Spec generated