%global _empty_manifest_terminate_build 0
Name: python-pytest-django
Version: 4.5.2
Release: 1
Summary: A Django plugin for pytest.
License: BSD-3-Clause
URL: https://pytest-django.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/42/6d6563165b82289d4a30ea477f85c04386303e51cf4e4e4651d4f9910830/pytest-django-4.5.2.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-Django
Requires: python3-django-configurations
%description
pytest-django allows you to test your Django project/applications with the
`pytest testing tool `_.
* `Quick start / tutorial
`_
* `Changelog `_
* Full documentation: https://pytest-django.readthedocs.io/en/latest/
* `Contribution docs
`_
* Version compatibility:
* Django: 2.2, 3.1, 3.2, 4.0 and latest main branch (compatible at the time of
each release)
* Python: CPython>=3.5 or PyPy 3
* pytest: >=5.4
For compatibility with older versions, use the pytest-django 3.*.* series.
* Licence: BSD
* Project maintainers: Andreas Pelme, Floris Bruynooghe and Daniel Hahler
* `All contributors `_
* GitHub repository: https://github.com/pytest-dev/pytest-django
* `Issue tracker `_
* `Python Package Index (PyPI) `_
%package -n python3-pytest-django
Summary: A Django plugin for pytest.
Provides: python-pytest-django
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-django
pytest-django allows you to test your Django project/applications with the
`pytest testing tool `_.
* `Quick start / tutorial
`_
* `Changelog `_
* Full documentation: https://pytest-django.readthedocs.io/en/latest/
* `Contribution docs
`_
* Version compatibility:
* Django: 2.2, 3.1, 3.2, 4.0 and latest main branch (compatible at the time of
each release)
* Python: CPython>=3.5 or PyPy 3
* pytest: >=5.4
For compatibility with older versions, use the pytest-django 3.*.* series.
* Licence: BSD
* Project maintainers: Andreas Pelme, Floris Bruynooghe and Daniel Hahler
* `All contributors `_
* GitHub repository: https://github.com/pytest-dev/pytest-django
* `Issue tracker `_
* `Python Package Index (PyPI) `_
%package help
Summary: Development documents and examples for pytest-django
Provides: python3-pytest-django-doc
%description help
pytest-django allows you to test your Django project/applications with the
`pytest testing tool `_.
* `Quick start / tutorial
`_
* `Changelog `_
* Full documentation: https://pytest-django.readthedocs.io/en/latest/
* `Contribution docs
`_
* Version compatibility:
* Django: 2.2, 3.1, 3.2, 4.0 and latest main branch (compatible at the time of
each release)
* Python: CPython>=3.5 or PyPy 3
* pytest: >=5.4
For compatibility with older versions, use the pytest-django 3.*.* series.
* Licence: BSD
* Project maintainers: Andreas Pelme, Floris Bruynooghe and Daniel Hahler
* `All contributors `_
* GitHub repository: https://github.com/pytest-dev/pytest-django
* `Issue tracker `_
* `Python Package Index (PyPI) `_
%prep
%autosetup -n pytest-django-4.5.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-django -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 4.5.2-1
- Package Spec generated