%global _empty_manifest_terminate_build 0
Name:		python-rosdep
Version:	0.22.1
Release:	1
Summary:	rosdep package manager abstraction tool for ROS
License:	BSD
URL:		http://wiki.ros.org/rosdep
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a3/8c/fc4836f9f20e1032f1240225218080a55e77b1a063f6dcd901d47ea7db45/rosdep-0.22.1.tar.gz
BuildArch:	noarch

Requires:	python3-PyYAML
Requires:	python3-catkin-pkg
Requires:	python3-rosdistro
Requires:	python3-rospkg
Requires:	python3-setuptools
Requires:	python3-flake8
Requires:	python3-flake8-comprehensions
Requires:	python3-pytest
Requires:	python3-mock

%description
Command-line tool for installing system dependencies on a variety of platforms.




%package -n python3-rosdep
Summary:	rosdep package manager abstraction tool for ROS
Provides:	python-rosdep
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-rosdep
Command-line tool for installing system dependencies on a variety of platforms.




%package help
Summary:	Development documents and examples for rosdep
Provides:	python3-rosdep-doc
%description help
Command-line tool for installing system dependencies on a variety of platforms.




%prep
%autosetup -n rosdep-0.22.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-rosdep -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.22.1-1
- Package Spec generated