%global _empty_manifest_terminate_build 0
Name: python-soco
Version: 0.29.1
Release: 1
Summary: SoCo (Sonos Controller) is a simple library to control Sonos speakers.
License: MIT License
URL: https://github.com/SoCo/SoCo
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/06/4436eeea01ea6bfae0baab2003bbd440ad42a083148357a5644ce93d09f2/soco-0.29.1.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-xmltodict
Requires: python3-ifaddr
Requires: python3-appdirs
Requires: python3-lxml
Requires: python3-aiohttp
%description
SoCo (Sonos Controller) is a Python library that allows you to
control `Sonos speakers`_ programmatically. It was originally created at `Music
Hack Day Sydney`_ by `Rahim Sonawalla`_ and is now developed by a `team of
people`_ at its `GitHub repository`_
For more background on the project, please see Rahim's `blog post
`_.
Visit the `SoCo documentation`_ for a more detailed overview of the functionailty.
%package -n python3-soco
Summary: SoCo (Sonos Controller) is a simple library to control Sonos speakers.
Provides: python-soco
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-soco
SoCo (Sonos Controller) is a Python library that allows you to
control `Sonos speakers`_ programmatically. It was originally created at `Music
Hack Day Sydney`_ by `Rahim Sonawalla`_ and is now developed by a `team of
people`_ at its `GitHub repository`_
For more background on the project, please see Rahim's `blog post
`_.
Visit the `SoCo documentation`_ for a more detailed overview of the functionailty.
%package help
Summary: Development documents and examples for soco
Provides: python3-soco-doc
%description help
SoCo (Sonos Controller) is a Python library that allows you to
control `Sonos speakers`_ programmatically. It was originally created at `Music
Hack Day Sydney`_ by `Rahim Sonawalla`_ and is now developed by a `team of
people`_ at its `GitHub repository`_
For more background on the project, please see Rahim's `blog post
`_.
Visit the `SoCo documentation`_ for a more detailed overview of the functionailty.
%prep
%autosetup -n soco-0.29.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-soco -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.29.1-1
- Package Spec generated