%global _empty_manifest_terminate_build 0
Name:		python-spdx-lookup
Version:	0.3.3
Release:	1
Summary:	SPDX license list query tool
License:	BSD-2-Clause
URL:		https://github.com/bbqsrc/spdx-lookup-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2f/ea/aad16afb2365fd84536a1dd42be115bb7079f56c3bc50c70257a3f4cfb94/spdx-lookup-0.3.3.tar.gz
BuildArch:	noarch

Requires:	python3-spdx

%description
A tool to query the SPDX license list.

%package -n python3-spdx-lookup
Summary:	SPDX license list query tool
Provides:	python-spdx-lookup
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-spdx-lookup
A tool to query the SPDX license list.

%package help
Summary:	Development documents and examples for spdx-lookup
Provides:	python3-spdx-lookup-doc
%description help
A tool to query the SPDX license list.

%prep
%autosetup -n spdx-lookup-0.3.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-spdx-lookup -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.3-1
- Package Spec generated