%global _empty_manifest_terminate_build 0
Name:		python-stdiomask
Version:	0.0.6
Release:	1
Summary:	A cross-platform Python module for entering passwords to a stdio terminal and displaying a **** mask, which getpass cannot do.
License:	GPLv3+
URL:		https://github.com/asweigart/stdiomask
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/47/a2/f72fd263cecb11ed4cc96bd31608359e1df30349c665674e5c35ea9a72d6/stdiomask-0.0.6.tar.gz
BuildArch:	noarch


%description
A cross-platform Python module for entering passwords to a stdio terminal and displaying a **** mask, which getpass cannot do.

%package -n python3-stdiomask
Summary:	A cross-platform Python module for entering passwords to a stdio terminal and displaying a **** mask, which getpass cannot do.
Provides:	python-stdiomask
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-stdiomask
A cross-platform Python module for entering passwords to a stdio terminal and displaying a **** mask, which getpass cannot do.

%package help
Summary:	Development documents and examples for stdiomask
Provides:	python3-stdiomask-doc
%description help
A cross-platform Python module for entering passwords to a stdio terminal and displaying a **** mask, which getpass cannot do.

%prep
%autosetup -n stdiomask-0.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-stdiomask -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.6-1
- Package Spec generated