%global _empty_manifest_terminate_build 0
Name:		python-xarray
Version:	2023.2.0
Release:	1
Summary:	N-D labeled arrays and datasets in Python
License:	Apache-2.0
URL:		https://github.com/pydata/xarray
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/01/be/ef024d1f3ecac9e8924165e4c5a4e948a08b051036021863548653b97eb5/xarray-2023.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-packaging
Requires:	python3-scipy
Requires:	python3-bottleneck
Requires:	python3-numbagg
Requires:	python3-flox
Requires:	python3-netCDF4
Requires:	python3-h5netcdf
Requires:	python3-scipy
Requires:	python3-zarr
Requires:	python3-fsspec
Requires:	python3-cftime
Requires:	python3-rasterio
Requires:	python3-cfgrib
Requires:	python3-pooch
Requires:	python3-bottleneck
Requires:	python3-numbagg
Requires:	python3-flox
Requires:	python3-dask[complete]
Requires:	python3-matplotlib
Requires:	python3-seaborn
Requires:	python3-nc-time-axis
Requires:	python3-pydap
Requires:	python3-netCDF4
Requires:	python3-h5netcdf
Requires:	python3-scipy
Requires:	python3-zarr
Requires:	python3-fsspec
Requires:	python3-cftime
Requires:	python3-rasterio
Requires:	python3-cfgrib
Requires:	python3-pooch
Requires:	python3-bottleneck
Requires:	python3-numbagg
Requires:	python3-flox
Requires:	python3-dask[complete]
Requires:	python3-matplotlib
Requires:	python3-seaborn
Requires:	python3-nc-time-axis
Requires:	python3-sphinx-autosummary-accessors
Requires:	python3-sphinx-rtd-theme
Requires:	python3-ipython
Requires:	python3-ipykernel
Requires:	python3-jupyter-client
Requires:	python3-nbsphinx
Requires:	python3-scanpydoc
Requires:	python3-pydap
Requires:	python3-netCDF4
Requires:	python3-h5netcdf
Requires:	python3-scipy
Requires:	python3-zarr
Requires:	python3-fsspec
Requires:	python3-cftime
Requires:	python3-rasterio
Requires:	python3-cfgrib
Requires:	python3-pooch
Requires:	python3-pydap
Requires:	python3-dask[complete]
Requires:	python3-matplotlib
Requires:	python3-seaborn
Requires:	python3-nc-time-axis

%description
Multi-dimensional (a.k.a. N-dimensional, ND) arrays (sometimes called
"tensors") are an essential part of computational science.
They are encountered in a wide range of fields, including physics, astronomy,
geoscience, bioinformatics, engineering, finance, and deep learning.
In Python, NumPy_ provides the fundamental data structure and API for
working with raw ND arrays.
However, real-world datasets are usually more than just raw numbers;
they have labels which encode information about how the array values map
to locations in space, time, etc.
xarray doesn't just keep track of labels on arrays -- it uses them to provide a
powerful and concise interface. For example:
-  Apply operations over dimensions by name: ``x.sum('time')``.
-  Select values by label instead of integer location: ``x.loc['2014-01-01']`` or ``x.sel(time='2014-01-01')``.
-  Mathematical operations (e.g., ``x - y``) vectorize across multiple dimensions (array broadcasting) based on dimension names, not shape.
-  Flexible split-apply-combine operations with groupby: ``x.groupby('time.dayofyear').mean()``.
-  Database like alignment based on coordinate labels that smoothly handles missing values: ``x, y = xr.align(x, y, join='outer')``.
-  Keep track of arbitrary metadata in the form of a Python dictionary: ``x.attrs``.

%package -n python3-xarray
Summary:	N-D labeled arrays and datasets in Python
Provides:	python-xarray
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-xarray
Multi-dimensional (a.k.a. N-dimensional, ND) arrays (sometimes called
"tensors") are an essential part of computational science.
They are encountered in a wide range of fields, including physics, astronomy,
geoscience, bioinformatics, engineering, finance, and deep learning.
In Python, NumPy_ provides the fundamental data structure and API for
working with raw ND arrays.
However, real-world datasets are usually more than just raw numbers;
they have labels which encode information about how the array values map
to locations in space, time, etc.
xarray doesn't just keep track of labels on arrays -- it uses them to provide a
powerful and concise interface. For example:
-  Apply operations over dimensions by name: ``x.sum('time')``.
-  Select values by label instead of integer location: ``x.loc['2014-01-01']`` or ``x.sel(time='2014-01-01')``.
-  Mathematical operations (e.g., ``x - y``) vectorize across multiple dimensions (array broadcasting) based on dimension names, not shape.
-  Flexible split-apply-combine operations with groupby: ``x.groupby('time.dayofyear').mean()``.
-  Database like alignment based on coordinate labels that smoothly handles missing values: ``x, y = xr.align(x, y, join='outer')``.
-  Keep track of arbitrary metadata in the form of a Python dictionary: ``x.attrs``.

%package help
Summary:	Development documents and examples for xarray
Provides:	python3-xarray-doc
%description help
Multi-dimensional (a.k.a. N-dimensional, ND) arrays (sometimes called
"tensors") are an essential part of computational science.
They are encountered in a wide range of fields, including physics, astronomy,
geoscience, bioinformatics, engineering, finance, and deep learning.
In Python, NumPy_ provides the fundamental data structure and API for
working with raw ND arrays.
However, real-world datasets are usually more than just raw numbers;
they have labels which encode information about how the array values map
to locations in space, time, etc.
xarray doesn't just keep track of labels on arrays -- it uses them to provide a
powerful and concise interface. For example:
-  Apply operations over dimensions by name: ``x.sum('time')``.
-  Select values by label instead of integer location: ``x.loc['2014-01-01']`` or ``x.sel(time='2014-01-01')``.
-  Mathematical operations (e.g., ``x - y``) vectorize across multiple dimensions (array broadcasting) based on dimension names, not shape.
-  Flexible split-apply-combine operations with groupby: ``x.groupby('time.dayofyear').mean()``.
-  Database like alignment based on coordinate labels that smoothly handles missing values: ``x, y = xr.align(x, y, join='outer')``.
-  Keep track of arbitrary metadata in the form of a Python dictionary: ``x.attrs``.

%prep
%autosetup -n xarray-2023.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-xarray -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.2.0-1
- Package Spec generated