%global _empty_manifest_terminate_build 0
Name:		python-colcon-common-extensions
Version:	0.3.0
Release:	1
Summary:	Meta package aggregating colcon-core and common extensions.
License:	Apache License, Version 2.0
URL:		https://colcon.readthedocs.io
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3c/5b/c4928b0fef2fdf1738b569aab9ed7f8bfa6a19df080b8c864f87552fa577/colcon-common-extensions-0.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-colcon-cmake
Requires:	python3-colcon-core
Requires:	python3-colcon-defaults
Requires:	python3-colcon-devtools
Requires:	python3-colcon-library-path
Requires:	python3-colcon-metadata
Requires:	python3-colcon-notification
Requires:	python3-colcon-output
Requires:	python3-colcon-package-information
Requires:	python3-colcon-package-selection
Requires:	python3-colcon-parallel-executor
Requires:	python3-colcon-powershell
Requires:	python3-colcon-python-setup-py
Requires:	python3-colcon-recursive-crawl
Requires:	python3-colcon-ros
Requires:	python3-colcon-test-result
Requires:	python3-colcon-argcomplete
Requires:	python3-colcon-bash
Requires:	python3-colcon-cd
Requires:	python3-colcon-zsh
Requires:	python3-colcon-override-check

%description
A meta package aggregating `colcon-core <https://github.com/colcon/colcon-core>`_ as well as a set of common extensions.

%package -n python3-colcon-common-extensions
Summary:	Meta package aggregating colcon-core and common extensions.
Provides:	python-colcon-common-extensions
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-colcon-common-extensions
A meta package aggregating `colcon-core <https://github.com/colcon/colcon-core>`_ as well as a set of common extensions.

%package help
Summary:	Development documents and examples for colcon-common-extensions
Provides:	python3-colcon-common-extensions-doc
%description help
A meta package aggregating `colcon-core <https://github.com/colcon/colcon-core>`_ as well as a set of common extensions.

%prep
%autosetup -n colcon-common-extensions-0.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-colcon-common-extensions -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
- Package Spec generated