%global _empty_manifest_terminate_build 0
Name: python-flask-oidc
Version: 1.4.0
Release: 1
Summary: OpenID Connect extension for Flask
License: BSD License
URL: https://github.com/puiterwijk/flask-oidc
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9a/de/402709ab3e67b2f52a552b4aaab66a051fec4c544d9cf0a88532f97c1634/flask-oidc-1.4.0.tar.gz
BuildArch: noarch
%description
`OpenID Connect `_ support for `Flask `_.
This library should work with any standards compliant OpenID Connect provider.
It has been tested with:
* `Google+ Login `_
* `Ipsilon `_
%package -n python3-flask-oidc
Summary: OpenID Connect extension for Flask
Provides: python-flask-oidc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flask-oidc
`OpenID Connect `_ support for `Flask `_.
This library should work with any standards compliant OpenID Connect provider.
It has been tested with:
* `Google+ Login `_
* `Ipsilon `_
%package help
Summary: Development documents and examples for flask-oidc
Provides: python3-flask-oidc-doc
%description help
`OpenID Connect `_ support for `Flask `_.
This library should work with any standards compliant OpenID Connect provider.
It has been tested with:
* `Google+ Login `_
* `Ipsilon `_
%prep
%autosetup -n flask-oidc-1.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flask-oidc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 1.4.0-1
- Package Spec generated