%global _empty_manifest_terminate_build 0
Name:		python-geopy
Version:	2.3.0
Release:	1
Summary:	Python Geocoding Toolbox
License:	MIT
URL:		https://github.com/geopy/geopy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b5/a7/3f45be21951e48e0f367b1c87b7e00d3a9cd054bee8b6e13a35b0f652c6f/geopy-2.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-geographiclib
Requires:	python3-aiohttp
Requires:	python3-coverage
Requires:	python3-flake8
Requires:	python3-isort
Requires:	python3-pytest-asyncio
Requires:	python3-pytest
Requires:	python3-readme-renderer
Requires:	python3-sphinx-issues
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-readme-renderer
Requires:	python3-sphinx
Requires:	python3-sphinx-issues
Requires:	python3-sphinx-rtd-theme
Requires:	python3-flake8
Requires:	python3-isort
Requires:	python3-coverage
Requires:	python3-pytest-asyncio
Requires:	python3-pytest
Requires:	python3-sphinx
Requires:	python3-urllib3
Requires:	python3-requests
Requires:	python3-pytz

%description
geopy is a Python client for several popular geocoding web
services.
geopy makes it easy for Python developers to locate the coordinates of
addresses, cities, countries, and landmarks across the globe using
third-party geocoders and other data sources.
geopy includes geocoder classes for the `OpenStreetMap Nominatim`_,
`Google Geocoding API (V3)`_, and many other geocoding services.
The full list is available on the `Geocoders doc section`_.
Geocoder classes are located in `geopy.geocoders`_.
geopy is tested against CPython (versions 3.7, 3.8, 3.9, 3.10, 3.11)
and PyPy3. geopy 1.x line also supported CPython 2.7, 3.4 and PyPy2.
© geopy contributors 2006-2018 (see AUTHORS) under the `MIT
License <https://github.com/geopy/geopy/blob/master/LICENSE>`__.

%package -n python3-geopy
Summary:	Python Geocoding Toolbox
Provides:	python-geopy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-geopy
geopy is a Python client for several popular geocoding web
services.
geopy makes it easy for Python developers to locate the coordinates of
addresses, cities, countries, and landmarks across the globe using
third-party geocoders and other data sources.
geopy includes geocoder classes for the `OpenStreetMap Nominatim`_,
`Google Geocoding API (V3)`_, and many other geocoding services.
The full list is available on the `Geocoders doc section`_.
Geocoder classes are located in `geopy.geocoders`_.
geopy is tested against CPython (versions 3.7, 3.8, 3.9, 3.10, 3.11)
and PyPy3. geopy 1.x line also supported CPython 2.7, 3.4 and PyPy2.
© geopy contributors 2006-2018 (see AUTHORS) under the `MIT
License <https://github.com/geopy/geopy/blob/master/LICENSE>`__.

%package help
Summary:	Development documents and examples for geopy
Provides:	python3-geopy-doc
%description help
geopy is a Python client for several popular geocoding web
services.
geopy makes it easy for Python developers to locate the coordinates of
addresses, cities, countries, and landmarks across the globe using
third-party geocoders and other data sources.
geopy includes geocoder classes for the `OpenStreetMap Nominatim`_,
`Google Geocoding API (V3)`_, and many other geocoding services.
The full list is available on the `Geocoders doc section`_.
Geocoder classes are located in `geopy.geocoders`_.
geopy is tested against CPython (versions 3.7, 3.8, 3.9, 3.10, 3.11)
and PyPy3. geopy 1.x line also supported CPython 2.7, 3.4 and PyPy2.
© geopy contributors 2006-2018 (see AUTHORS) under the `MIT
License <https://github.com/geopy/geopy/blob/master/LICENSE>`__.

%prep
%autosetup -n geopy-2.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-geopy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.0-1
- Package Spec generated