%global _empty_manifest_terminate_build 0
Name:		python-jedi
Version:	0.18.2
Release:	1
Summary:	An autocompletion tool for Python that can be used for text editors.
License:	MIT
URL:		https://github.com/davidhalter/jedi
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/15/02/afd43c5066de05f6b3188f3aa74136a3289e6c30e7a45f351546cab0928c/jedi-0.18.2.tar.gz
BuildArch:	noarch

Requires:	python3-parso
Requires:	python3-Jinja2
Requires:	python3-MarkupSafe
Requires:	python3-Pygments
Requires:	python3-alabaster
Requires:	python3-babel
Requires:	python3-chardet
Requires:	python3-commonmark
Requires:	python3-docutils
Requires:	python3-future
Requires:	python3-idna
Requires:	python3-imagesize
Requires:	python3-mock
Requires:	python3-packaging
Requires:	python3-pyparsing
Requires:	python3-pytz
Requires:	python3-readthedocs-sphinx-ext
Requires:	python3-recommonmark
Requires:	python3-requests
Requires:	python3-six
Requires:	python3-snowballstemmer
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx
Requires:	python3-sphinxcontrib-serializinghtml
Requires:	python3-sphinxcontrib-websupport
Requires:	python3-urllib3
Requires:	python3-flake8
Requires:	python3-mypy
Requires:	python3-Django
Requires:	python3-attrs
Requires:	python3-colorama
Requires:	python3-docopt
Requires:	python3-pytest

%description
You can file issues and questions in the `issue tracker
<https://github.com/davidhalter/jedi/>`. Alternatively you can also ask on
`Stack Overflow <https://stackoverflow.com/questions/tagged/python-jedi>`_ with
the label ``python-jedi``.

%package -n python3-jedi
Summary:	An autocompletion tool for Python that can be used for text editors.
Provides:	python-jedi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-jedi
You can file issues and questions in the `issue tracker
<https://github.com/davidhalter/jedi/>`. Alternatively you can also ask on
`Stack Overflow <https://stackoverflow.com/questions/tagged/python-jedi>`_ with
the label ``python-jedi``.

%package help
Summary:	Development documents and examples for jedi
Provides:	python3-jedi-doc
%description help
You can file issues and questions in the `issue tracker
<https://github.com/davidhalter/jedi/>`. Alternatively you can also ask on
`Stack Overflow <https://stackoverflow.com/questions/tagged/python-jedi>`_ with
the label ``python-jedi``.

%prep
%autosetup -n jedi-0.18.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-jedi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.18.2-1
- Package Spec generated