%global _empty_manifest_terminate_build 0
Name:		python-pybalboa
Version:	1.0.1
Release:	1
Summary:	Module to communicate with a Balboa spa wifi adapter.
License:	Apache 2.0
URL:		https://github.com/garbled1/pybalboa
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/54/3d/e31ebf17887c97941fb607bf71ccca37d451b45ab616cba55143010ee39d/pybalboa-1.0.1.tar.gz
BuildArch:	noarch


%description
Python Module to interface with a balboa spa
Requires Python 3 with asyncio.
To Install::
  pip install pybalboa
To test::
  python3 pybalboa <ip-of-spa-wifi> <debug-flag>
To Use
``````
See ``__main__.py`` for usage examples.
Minimal example::
  import asyncio
  import pybalboa
  async with pybalboa.SpaClient(spa_host) as spa:
    # read/run spa commands
  return
Related
```````
- https://github.com/ccutrer/balboa_worldwide_app/wiki - invaluable wiki for Balboa module protocol

%package -n python3-pybalboa
Summary:	Module to communicate with a Balboa spa wifi adapter.
Provides:	python-pybalboa
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pybalboa
Python Module to interface with a balboa spa
Requires Python 3 with asyncio.
To Install::
  pip install pybalboa
To test::
  python3 pybalboa <ip-of-spa-wifi> <debug-flag>
To Use
``````
See ``__main__.py`` for usage examples.
Minimal example::
  import asyncio
  import pybalboa
  async with pybalboa.SpaClient(spa_host) as spa:
    # read/run spa commands
  return
Related
```````
- https://github.com/ccutrer/balboa_worldwide_app/wiki - invaluable wiki for Balboa module protocol

%package help
Summary:	Development documents and examples for pybalboa
Provides:	python3-pybalboa-doc
%description help
Python Module to interface with a balboa spa
Requires Python 3 with asyncio.
To Install::
  pip install pybalboa
To test::
  python3 pybalboa <ip-of-spa-wifi> <debug-flag>
To Use
``````
See ``__main__.py`` for usage examples.
Minimal example::
  import asyncio
  import pybalboa
  async with pybalboa.SpaClient(spa_host) as spa:
    # read/run spa commands
  return
Related
```````
- https://github.com/ccutrer/balboa_worldwide_app/wiki - invaluable wiki for Balboa module protocol

%prep
%autosetup -n pybalboa-1.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pybalboa -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
- Package Spec generated