%global _empty_manifest_terminate_build 0
Name:		python-pyhcl
Version:	0.4.4
Release:	1
Summary:	HCL configuration parser for python
License:	Mozilla Public License 2.0 (MPL 2.0)
URL:		https://github.com/virtuald/pyhcl
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/91/b0/dd4f1d01b77be3b66d9f550ed958b68fa553764be1d27c7d604906c06b42/pyhcl-0.4.4.tar.gz
BuildArch:	noarch


%description
|Build Status|
Implements a parser for `HCL (HashiCorp Configuration
Language) <https://github.com/hashicorp/hcl>`__ in Python. This
implementation aims to be compatible with the original golang version of
the parser.
The grammar and many of the tests/fixtures were copied/ported from the
golang parser into pyhcl. All releases are tested with a variety of 
python versions from Python 2.7 onward.
This version has been modified to work with terraform 0.12 syntax.  
It should be backward compatible with earlier versions.  
It doesn't cover every situation.  See discussion in pull request:
https://github.com/virtuald/pyhcl/pull/57

%package -n python3-pyhcl
Summary:	HCL configuration parser for python
Provides:	python-pyhcl
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyhcl
|Build Status|
Implements a parser for `HCL (HashiCorp Configuration
Language) <https://github.com/hashicorp/hcl>`__ in Python. This
implementation aims to be compatible with the original golang version of
the parser.
The grammar and many of the tests/fixtures were copied/ported from the
golang parser into pyhcl. All releases are tested with a variety of 
python versions from Python 2.7 onward.
This version has been modified to work with terraform 0.12 syntax.  
It should be backward compatible with earlier versions.  
It doesn't cover every situation.  See discussion in pull request:
https://github.com/virtuald/pyhcl/pull/57

%package help
Summary:	Development documents and examples for pyhcl
Provides:	python3-pyhcl-doc
%description help
|Build Status|
Implements a parser for `HCL (HashiCorp Configuration
Language) <https://github.com/hashicorp/hcl>`__ in Python. This
implementation aims to be compatible with the original golang version of
the parser.
The grammar and many of the tests/fixtures were copied/ported from the
golang parser into pyhcl. All releases are tested with a variety of 
python versions from Python 2.7 onward.
This version has been modified to work with terraform 0.12 syntax.  
It should be backward compatible with earlier versions.  
It doesn't cover every situation.  See discussion in pull request:
https://github.com/virtuald/pyhcl/pull/57

%prep
%autosetup -n pyhcl-0.4.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyhcl -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.4-1
- Package Spec generated