%global _empty_manifest_terminate_build 0
Name: python-pyls-spyder
Version: 0.4.0
Release: 1
Summary: Spyder extensions for the python-lsp-server
License: MIT
URL: https://github.com/spyder-ide/pyls-spyder
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/94/e0/17ebfbc3cdd9d2bed54f4904672d8c766b5f48c930d699e20566061b6720/pyls-spyder-0.4.0.tar.gz
BuildArch: noarch
Requires: python3-lsp-server
%description
# pyls-spyder
[![Project License - MIT](https://img.shields.io/pypi/l/pyls-spyder.svg)](https://raw.githubusercontent.com/spyder-ide/pyls-spyder/master/LICENSE)
[![pypi version](https://img.shields.io/pypi/v/pyls-spyder.svg)](https://pypi.org/project/pyls-spyder/)
[![conda version](https://img.shields.io/conda/vn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![download count](https://img.shields.io/conda/dn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![Downloads](https://pepy.tech/badge/pyls-spyder)](https://pepy.tech/project/pyls-spyder)
[![PyPI status](https://img.shields.io/pypi/status/pyls-spyder.svg)](https://github.com/spyder-ide/pyls-spyder)
![PyLS-Spyder tests](https://github.com/spyder-ide/pyls-spyder/workflows/PyLS-Spyder%20tests/badge.svg)
*Copyright © 2020– Spyder Project Contributors*
## Overview
Spyder extensions for the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) (pylsp). This package provides Spyder-specific extras for the [Language Server Protocol](https://microsoft.github.io/language-server-protocol/specifications/specification-current/) (LSP) on Python, such as document symbol searching and others.
## Installing
To install pyls-spyder, you can use both conda or pip package managers:
```bash
# Using conda (Recommended)
conda install pyls-spyder -c spyder-ide
# Using pip
pip install pyls-spyder
```
## Dependencies
This package depends on the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) to integrate the Spyder-specific extensions.
## Installing locally
To install and develop spyder-pyls locally, you will need to install the python-lsp-server:
```bash
# Using conda
conda install python-lsp-server
# Using pip
pip install python-lsp-server
```
Then, you can install the package locally using pip:
```bash
pip install -U -e .
```
## Running tests
We use pytest to run tests as it follows:
```bash
pytest -x -v pyls_spyder/tests
```
## Extended LSP calls
| LSP method | Spyder extensions |
|:-----------------------------:|:------------------------------------------------:|
| `textDocument/documentSymbol` | Find code cells `# %%` and block comments `# --` |
| `textDocument/foldingRange` | Return code cells `# %%` as code folding regions |
## Plugin configuration options
This plugin can be configured by using the key `pyls_spyder` when calling `workspace/didChangeConfiguration` on the pyls. Each configuration option is described below:
LSP method |
Configuration Key |
Type |
Description |
textDocument/documentSymbol |
group_cells |
bool |
Enable/Disable code cell grouping according to the total number of leading percentages |
enable_block_comments |
bool |
Enable/disable block comment detection |
## Changelog
Please see our [CHANGELOG](https://github.com/spyder-ide/pyls-spyder/blob/master/CHANGELOG.md) file to learn more about our new features and improvements.
## Contribution guidelines
We follow PEP8 and PEP257 for all Python modules. We use MyPy type annotations for all functions and classes declared on this package. Feel free to send a PR or create an issue if you have any problem/question.
%package -n python3-pyls-spyder
Summary: Spyder extensions for the python-lsp-server
Provides: python-pyls-spyder
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyls-spyder
# pyls-spyder
[![Project License - MIT](https://img.shields.io/pypi/l/pyls-spyder.svg)](https://raw.githubusercontent.com/spyder-ide/pyls-spyder/master/LICENSE)
[![pypi version](https://img.shields.io/pypi/v/pyls-spyder.svg)](https://pypi.org/project/pyls-spyder/)
[![conda version](https://img.shields.io/conda/vn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![download count](https://img.shields.io/conda/dn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![Downloads](https://pepy.tech/badge/pyls-spyder)](https://pepy.tech/project/pyls-spyder)
[![PyPI status](https://img.shields.io/pypi/status/pyls-spyder.svg)](https://github.com/spyder-ide/pyls-spyder)
![PyLS-Spyder tests](https://github.com/spyder-ide/pyls-spyder/workflows/PyLS-Spyder%20tests/badge.svg)
*Copyright © 2020– Spyder Project Contributors*
## Overview
Spyder extensions for the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) (pylsp). This package provides Spyder-specific extras for the [Language Server Protocol](https://microsoft.github.io/language-server-protocol/specifications/specification-current/) (LSP) on Python, such as document symbol searching and others.
## Installing
To install pyls-spyder, you can use both conda or pip package managers:
```bash
# Using conda (Recommended)
conda install pyls-spyder -c spyder-ide
# Using pip
pip install pyls-spyder
```
## Dependencies
This package depends on the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) to integrate the Spyder-specific extensions.
## Installing locally
To install and develop spyder-pyls locally, you will need to install the python-lsp-server:
```bash
# Using conda
conda install python-lsp-server
# Using pip
pip install python-lsp-server
```
Then, you can install the package locally using pip:
```bash
pip install -U -e .
```
## Running tests
We use pytest to run tests as it follows:
```bash
pytest -x -v pyls_spyder/tests
```
## Extended LSP calls
| LSP method | Spyder extensions |
|:-----------------------------:|:------------------------------------------------:|
| `textDocument/documentSymbol` | Find code cells `# %%` and block comments `# --` |
| `textDocument/foldingRange` | Return code cells `# %%` as code folding regions |
## Plugin configuration options
This plugin can be configured by using the key `pyls_spyder` when calling `workspace/didChangeConfiguration` on the pyls. Each configuration option is described below:
LSP method |
Configuration Key |
Type |
Description |
textDocument/documentSymbol |
group_cells |
bool |
Enable/Disable code cell grouping according to the total number of leading percentages |
enable_block_comments |
bool |
Enable/disable block comment detection |
## Changelog
Please see our [CHANGELOG](https://github.com/spyder-ide/pyls-spyder/blob/master/CHANGELOG.md) file to learn more about our new features and improvements.
## Contribution guidelines
We follow PEP8 and PEP257 for all Python modules. We use MyPy type annotations for all functions and classes declared on this package. Feel free to send a PR or create an issue if you have any problem/question.
%package help
Summary: Development documents and examples for pyls-spyder
Provides: python3-pyls-spyder-doc
%description help
# pyls-spyder
[![Project License - MIT](https://img.shields.io/pypi/l/pyls-spyder.svg)](https://raw.githubusercontent.com/spyder-ide/pyls-spyder/master/LICENSE)
[![pypi version](https://img.shields.io/pypi/v/pyls-spyder.svg)](https://pypi.org/project/pyls-spyder/)
[![conda version](https://img.shields.io/conda/vn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![download count](https://img.shields.io/conda/dn/conda-forge/pyls-spyder.svg)](https://www.anaconda.com/download/)
[![Downloads](https://pepy.tech/badge/pyls-spyder)](https://pepy.tech/project/pyls-spyder)
[![PyPI status](https://img.shields.io/pypi/status/pyls-spyder.svg)](https://github.com/spyder-ide/pyls-spyder)
![PyLS-Spyder tests](https://github.com/spyder-ide/pyls-spyder/workflows/PyLS-Spyder%20tests/badge.svg)
*Copyright © 2020– Spyder Project Contributors*
## Overview
Spyder extensions for the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) (pylsp). This package provides Spyder-specific extras for the [Language Server Protocol](https://microsoft.github.io/language-server-protocol/specifications/specification-current/) (LSP) on Python, such as document symbol searching and others.
## Installing
To install pyls-spyder, you can use both conda or pip package managers:
```bash
# Using conda (Recommended)
conda install pyls-spyder -c spyder-ide
# Using pip
pip install pyls-spyder
```
## Dependencies
This package depends on the [python-lsp-server](https://github.com/python-lsp/python-lsp-server) to integrate the Spyder-specific extensions.
## Installing locally
To install and develop spyder-pyls locally, you will need to install the python-lsp-server:
```bash
# Using conda
conda install python-lsp-server
# Using pip
pip install python-lsp-server
```
Then, you can install the package locally using pip:
```bash
pip install -U -e .
```
## Running tests
We use pytest to run tests as it follows:
```bash
pytest -x -v pyls_spyder/tests
```
## Extended LSP calls
| LSP method | Spyder extensions |
|:-----------------------------:|:------------------------------------------------:|
| `textDocument/documentSymbol` | Find code cells `# %%` and block comments `# --` |
| `textDocument/foldingRange` | Return code cells `# %%` as code folding regions |
## Plugin configuration options
This plugin can be configured by using the key `pyls_spyder` when calling `workspace/didChangeConfiguration` on the pyls. Each configuration option is described below:
LSP method |
Configuration Key |
Type |
Description |
textDocument/documentSymbol |
group_cells |
bool |
Enable/Disable code cell grouping according to the total number of leading percentages |
enable_block_comments |
bool |
Enable/disable block comment detection |
## Changelog
Please see our [CHANGELOG](https://github.com/spyder-ide/pyls-spyder/blob/master/CHANGELOG.md) file to learn more about our new features and improvements.
## Contribution guidelines
We follow PEP8 and PEP257 for all Python modules. We use MyPy type annotations for all functions and classes declared on this package. Feel free to send a PR or create an issue if you have any problem/question.
%prep
%autosetup -n pyls-spyder-0.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyls-spyder -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 0.4.0-1
- Package Spec generated