%global _empty_manifest_terminate_build 0
Name: python-pytest-watch
Version: 4.2.0
Release: 1
Summary: Local continuous test runner with pytest and watchdog.
License: MIT
URL: http://github.com/joeyespo/pytest-watch
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/36/47/ab65fc1d682befc318c439940f81a0de1026048479f732e84fe714cd69c0/pytest-watch-4.2.0.tar.gz
BuildArch: noarch
%description
`Current version on PyPI `__
`Say Thanks! `__
**pytest-watch** a zero-config CLI tool that runs
`pytest `__, and re-runs it when a file in your
project changes. It beeps on failures and can run arbitrary commands on
each passing and failing test run.
%package -n python3-pytest-watch
Summary: Local continuous test runner with pytest and watchdog.
Provides: python-pytest-watch
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytest-watch
`Current version on PyPI `__
`Say Thanks! `__
**pytest-watch** a zero-config CLI tool that runs
`pytest `__, and re-runs it when a file in your
project changes. It beeps on failures and can run arbitrary commands on
each passing and failing test run.
%package help
Summary: Development documents and examples for pytest-watch
Provides: python3-pytest-watch-doc
%description help
`Current version on PyPI `__
`Say Thanks! `__
**pytest-watch** a zero-config CLI tool that runs
`pytest `__, and re-runs it when a file in your
project changes. It beeps on failures and can run arbitrary commands on
each passing and failing test run.
%prep
%autosetup -n pytest-watch-4.2.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytest-watch -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 4.2.0-1
- Package Spec generated