%global _empty_manifest_terminate_build 0
Name:		python-pytools
Version:	2022.1.14
Release:	1
Summary:	A collection of tools for Python
License:	MIT
URL:		http://pypi.python.org/pypi/pytools
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b5/00/b7350b62803926f1d8fbbcaa50e38bcc93354aa73894c13155825eec897f/pytools-2022.1.14.tar.gz
BuildArch:	noarch


%description
Pytools is a big bag of things that are "missing" from the Python standard
library. This is mainly a dependency of my other software packages, and is
probably of little interest to you unless you use those. If you're curious
nonetheless, here's what's on offer:
* A ton of small tool functions such as `len_iterable`, `argmin`,
  tuple generation, permutation generation, ASCII table pretty printing,
  GvR's monkeypatch_xxx() hack, the elusive `flatten`, and much more.
* A time-series logging module, `pytools.log`.
* Batch job submission, `pytools.batchjob`.
* A lexer, `pytools.lex`.
Links:
* `Documentation <https://documen.tician.de/pytools>`_
* `Github <https://github.com/inducer/pytools>`_
* ``pytools.log`` has been spun out into a separate project,
  `logpyle <https://github.com/illinois-ceesd/logpyle>`__.

%package -n python3-pytools
Summary:	A collection of tools for Python
Provides:	python-pytools
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytools
Pytools is a big bag of things that are "missing" from the Python standard
library. This is mainly a dependency of my other software packages, and is
probably of little interest to you unless you use those. If you're curious
nonetheless, here's what's on offer:
* A ton of small tool functions such as `len_iterable`, `argmin`,
  tuple generation, permutation generation, ASCII table pretty printing,
  GvR's monkeypatch_xxx() hack, the elusive `flatten`, and much more.
* A time-series logging module, `pytools.log`.
* Batch job submission, `pytools.batchjob`.
* A lexer, `pytools.lex`.
Links:
* `Documentation <https://documen.tician.de/pytools>`_
* `Github <https://github.com/inducer/pytools>`_
* ``pytools.log`` has been spun out into a separate project,
  `logpyle <https://github.com/illinois-ceesd/logpyle>`__.

%package help
Summary:	Development documents and examples for pytools
Provides:	python3-pytools-doc
%description help
Pytools is a big bag of things that are "missing" from the Python standard
library. This is mainly a dependency of my other software packages, and is
probably of little interest to you unless you use those. If you're curious
nonetheless, here's what's on offer:
* A ton of small tool functions such as `len_iterable`, `argmin`,
  tuple generation, permutation generation, ASCII table pretty printing,
  GvR's monkeypatch_xxx() hack, the elusive `flatten`, and much more.
* A time-series logging module, `pytools.log`.
* Batch job submission, `pytools.batchjob`.
* A lexer, `pytools.lex`.
Links:
* `Documentation <https://documen.tician.de/pytools>`_
* `Github <https://github.com/inducer/pytools>`_
* ``pytools.log`` has been spun out into a separate project,
  `logpyle <https://github.com/illinois-ceesd/logpyle>`__.

%prep
%autosetup -n pytools-2022.1.14

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytools -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 2022.1.14-1
- Package Spec generated