%global _empty_manifest_terminate_build 0
Name: python-sybil
Version: 5.0.0
Release: 1
Summary: Automated testing for the examples in your code and documentation.
License: MIT
URL: https://github.com/simplistix/sybil
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d6/de/488962831314a1a2a8be0acdaca7d8818bcd651d2744d92bc76a048deb09/sybil-5.0.0.tar.gz
BuildArch: noarch
Requires: python3-furo
Requires: python3-sphinx
Requires: python3-twine
Requires: python3-wheel
Requires: python3-myst-parser
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-seedir
Requires: python3-testfixtures
%description
|CircleCI|_ |Docs|_
This library provides a way to check examples in your code and documentation by parsing
them from their source and evaluating the parsed examples as part of
your normal test run. Integration is provided for the main Python test
runners.
The `documentation `__ is the best place to start.
%package -n python3-sybil
Summary: Automated testing for the examples in your code and documentation.
Provides: python-sybil
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sybil
|CircleCI|_ |Docs|_
This library provides a way to check examples in your code and documentation by parsing
them from their source and evaluating the parsed examples as part of
your normal test run. Integration is provided for the main Python test
runners.
The `documentation `__ is the best place to start.
%package help
Summary: Development documents and examples for sybil
Provides: python3-sybil-doc
%description help
|CircleCI|_ |Docs|_
This library provides a way to check examples in your code and documentation by parsing
them from their source and evaluating the parsed examples as part of
your normal test run. Integration is provided for the main Python test
runners.
The `documentation `__ is the best place to start.
%prep
%autosetup -n sybil-5.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sybil -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 5.0.0-1
- Package Spec generated