%global _empty_manifest_terminate_build 0
Name: python-yourls
Version: 1.2.3
Release: 1
Summary: Python client for YOURLS.
License: MIT
URL: https://github.com/razerm/yourls-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a4/c6/8f8a43d7bedaf7e247dd1a32e6a6297c795cf58dd028654d2d54194be4e5/yourls-1.2.3.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-logbook
Requires: python3-represent
Requires: python3-requests
Requires: python3-six
Requires: python3-coverage
Requires: python3-doc8
Requires: python3-flake8
Requires: python3-flake8-coding
Requires: python3-flake8-future-import
Requires: python3-pep8-naming
Requires: python3-plumbum
Requires: python3-pyenchant
Requires: python3-shovel
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-sphinxcontrib-spelling
Requires: python3-tox
Requires: python3-watchdog
Requires: python3-pytest
Requires: python3-responses
Requires: python3-mock
Requires: python3-pytest
Requires: python3-responses
Requires: python3-mock
%description
|PyPI Version| |Documentation| |Travis| |Coverage| |Python Version| |MIT License|
Installation
~~~~~~~~~~~~
$ pip install yourls
Example
~~~~~~~
>>> from yourls import YOURLSClient
>>> yourls = YOURLSClient('http://example.com/yourls-api.php', signature='6f344c2a8p')
>>> yourls.shorten('http://google.com')
ShortenedURL(
shorturl='http://example.com/abcde',
url='http://google.com',
title='Google',
date=datetime.datetime(2015, 10, 31, 14, 31, 4),
ip='203.0.113.0',
clicks=0,
keyword='abcde')
Documentation
~~~~~~~~~~~~~
For in-depth information, `visit the
documentation `__!
%package -n python3-yourls
Summary: Python client for YOURLS.
Provides: python-yourls
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-yourls
|PyPI Version| |Documentation| |Travis| |Coverage| |Python Version| |MIT License|
Installation
~~~~~~~~~~~~
$ pip install yourls
Example
~~~~~~~
>>> from yourls import YOURLSClient
>>> yourls = YOURLSClient('http://example.com/yourls-api.php', signature='6f344c2a8p')
>>> yourls.shorten('http://google.com')
ShortenedURL(
shorturl='http://example.com/abcde',
url='http://google.com',
title='Google',
date=datetime.datetime(2015, 10, 31, 14, 31, 4),
ip='203.0.113.0',
clicks=0,
keyword='abcde')
Documentation
~~~~~~~~~~~~~
For in-depth information, `visit the
documentation `__!
%package help
Summary: Development documents and examples for yourls
Provides: python3-yourls-doc
%description help
|PyPI Version| |Documentation| |Travis| |Coverage| |Python Version| |MIT License|
Installation
~~~~~~~~~~~~
$ pip install yourls
Example
~~~~~~~
>>> from yourls import YOURLSClient
>>> yourls = YOURLSClient('http://example.com/yourls-api.php', signature='6f344c2a8p')
>>> yourls.shorten('http://google.com')
ShortenedURL(
shorturl='http://example.com/abcde',
url='http://google.com',
title='Google',
date=datetime.datetime(2015, 10, 31, 14, 31, 4),
ip='203.0.113.0',
clicks=0,
keyword='abcde')
Documentation
~~~~~~~~~~~~~
For in-depth information, `visit the
documentation `__!
%prep
%autosetup -n yourls-1.2.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-yourls -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.2.3-1
- Package Spec generated