%global _empty_manifest_terminate_build 0
Name: python-google-crc32c
Version: 1.5.0
Release: 1
Summary: A python wrapper of the C library 'Google CRC32C'
License: Apache 2.0
URL: https://github.com/googleapis/python-crc32c
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d3/a5/4bb58448fffd36ede39684044df93a396c13d1ea3516f585767f9f960352/google-crc32c-1.5.0.tar.gz
Requires: python3-pytest
%description
# `google-crc32c`
![GA](https://img.shields.io/badge/support-GA-gold.svg) [](https://pypi.org/project/google-crc32c) ![Python Versions](https://img.shields.io/pypi/pyversions/google-crc32c)
This package wraps the [`google/crc32c`](https://github.com/google/crc32c)
hardware-based implementation of the CRC32C hashing algorithm. Multiple wheels
are distributed as well as source. If a wheel is not published for the python
version and platform you are using, you will need to compile crc32c using a
C toolchain.
# Currently Published Wheels
Wheels are currently published for Python 3.7, 3.8, 3.9, 3.10, 3.11 and
pypy-3.7 for multiple architectures. For information on building your own,
please view [BUILDING.md](BUILDING.md).
## Linux
Wheels are published for the following platforms / architectures:
- `manylinux2010` platform, `x86_64` and `1686` architectures
- `manylinux2014` platform, `aarch64` architecture
### Deprecated
- `manylinux1` platform, `x86_64` architecture wheels will be built until
2021-12-31, when the PyPA group drops support for the `manylinux1` image.
See: https://github.com/pypa/manylinux/issues/994
## Mac OS
Wheels are published for `x86_64` and `universal2` architectures.
## Windows
Wheels are published for `win32` and `win_amd64` architectures.
%package -n python3-google-crc32c
Summary: A python wrapper of the C library 'Google CRC32C'
Provides: python-google-crc32c
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-google-crc32c
# `google-crc32c`
![GA](https://img.shields.io/badge/support-GA-gold.svg) [](https://pypi.org/project/google-crc32c) ![Python Versions](https://img.shields.io/pypi/pyversions/google-crc32c)
This package wraps the [`google/crc32c`](https://github.com/google/crc32c)
hardware-based implementation of the CRC32C hashing algorithm. Multiple wheels
are distributed as well as source. If a wheel is not published for the python
version and platform you are using, you will need to compile crc32c using a
C toolchain.
# Currently Published Wheels
Wheels are currently published for Python 3.7, 3.8, 3.9, 3.10, 3.11 and
pypy-3.7 for multiple architectures. For information on building your own,
please view [BUILDING.md](BUILDING.md).
## Linux
Wheels are published for the following platforms / architectures:
- `manylinux2010` platform, `x86_64` and `1686` architectures
- `manylinux2014` platform, `aarch64` architecture
### Deprecated
- `manylinux1` platform, `x86_64` architecture wheels will be built until
2021-12-31, when the PyPA group drops support for the `manylinux1` image.
See: https://github.com/pypa/manylinux/issues/994
## Mac OS
Wheels are published for `x86_64` and `universal2` architectures.
## Windows
Wheels are published for `win32` and `win_amd64` architectures.
%package help
Summary: Development documents and examples for google-crc32c
Provides: python3-google-crc32c-doc
%description help
# `google-crc32c`
![GA](https://img.shields.io/badge/support-GA-gold.svg) [](https://pypi.org/project/google-crc32c) ![Python Versions](https://img.shields.io/pypi/pyversions/google-crc32c)
This package wraps the [`google/crc32c`](https://github.com/google/crc32c)
hardware-based implementation of the CRC32C hashing algorithm. Multiple wheels
are distributed as well as source. If a wheel is not published for the python
version and platform you are using, you will need to compile crc32c using a
C toolchain.
# Currently Published Wheels
Wheels are currently published for Python 3.7, 3.8, 3.9, 3.10, 3.11 and
pypy-3.7 for multiple architectures. For information on building your own,
please view [BUILDING.md](BUILDING.md).
## Linux
Wheels are published for the following platforms / architectures:
- `manylinux2010` platform, `x86_64` and `1686` architectures
- `manylinux2014` platform, `aarch64` architecture
### Deprecated
- `manylinux1` platform, `x86_64` architecture wheels will be built until
2021-12-31, when the PyPA group drops support for the `manylinux1` image.
See: https://github.com/pypa/manylinux/issues/994
## Mac OS
Wheels are published for `x86_64` and `universal2` architectures.
## Windows
Wheels are published for `win32` and `win_amd64` architectures.
%prep
%autosetup -n google-crc32c-1.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-google-crc32c -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.5.0-1
- Package Spec generated