%global _empty_manifest_terminate_build 0
Name:		python-xlrd
Version:	2.0.1
Release:	1
Summary:	Library for developers to extract data from Microsoft Excel (tm) .xls spreadsheet files
License:	BSD
URL:		http://www.python-excel.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a6/b3/19a2540d21dea5f908304375bd43f5ed7a4c28a370dc9122c565423e6b44/xlrd-2.0.1.tar.gz
BuildArch:	noarch

Requires:	python3-wheel
Requires:	python3-twine
Requires:	python3-sphinx
Requires:	python3-pytest
Requires:	python3-pytest-cov

%description
|Build Status|_ |Coverage Status|_ |Documentation|_ |PyPI version|_
xlrd is a library for reading data and formatting information from Excel
files in the historical ``.xls`` format.
  This library will no longer read anything other than ``.xls`` files. For
  alternatives that read newer file formats, please see http://www.python-excel.org/.
The following are also not supported but will safely and reliably be ignored:
*   Charts, Macros, Pictures, any other embedded object, **including** embedded worksheets.
*   VBA modules
*   Formulas, but results of formula calculations are extracted.
*   Comments
*   Hyperlinks
*   Autofilters, advanced filters, pivot tables, conditional formatting, data validation
Password-protected files are not supported and cannot be read by this library.
Quick start:
    import xlrd
    book = xlrd.open_workbook("myfile.xls")
    print("The number of worksheets is {0}".format(book.nsheets))
    print("Worksheet name(s): {0}".format(book.sheet_names()))
    sh = book.sheet_by_index(0)
    print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
    print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
    for rx in range(sh.nrows):
        print(sh.row(rx))
From the command line, this will show the first, second and last rows of each sheet in each file:
    python PYDIR/scripts/runxlrd.py 3rows *blah*.xls

%package -n python3-xlrd
Summary:	Library for developers to extract data from Microsoft Excel (tm) .xls spreadsheet files
Provides:	python-xlrd
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-xlrd
|Build Status|_ |Coverage Status|_ |Documentation|_ |PyPI version|_
xlrd is a library for reading data and formatting information from Excel
files in the historical ``.xls`` format.
  This library will no longer read anything other than ``.xls`` files. For
  alternatives that read newer file formats, please see http://www.python-excel.org/.
The following are also not supported but will safely and reliably be ignored:
*   Charts, Macros, Pictures, any other embedded object, **including** embedded worksheets.
*   VBA modules
*   Formulas, but results of formula calculations are extracted.
*   Comments
*   Hyperlinks
*   Autofilters, advanced filters, pivot tables, conditional formatting, data validation
Password-protected files are not supported and cannot be read by this library.
Quick start:
    import xlrd
    book = xlrd.open_workbook("myfile.xls")
    print("The number of worksheets is {0}".format(book.nsheets))
    print("Worksheet name(s): {0}".format(book.sheet_names()))
    sh = book.sheet_by_index(0)
    print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
    print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
    for rx in range(sh.nrows):
        print(sh.row(rx))
From the command line, this will show the first, second and last rows of each sheet in each file:
    python PYDIR/scripts/runxlrd.py 3rows *blah*.xls

%package help
Summary:	Development documents and examples for xlrd
Provides:	python3-xlrd-doc
%description help
|Build Status|_ |Coverage Status|_ |Documentation|_ |PyPI version|_
xlrd is a library for reading data and formatting information from Excel
files in the historical ``.xls`` format.
  This library will no longer read anything other than ``.xls`` files. For
  alternatives that read newer file formats, please see http://www.python-excel.org/.
The following are also not supported but will safely and reliably be ignored:
*   Charts, Macros, Pictures, any other embedded object, **including** embedded worksheets.
*   VBA modules
*   Formulas, but results of formula calculations are extracted.
*   Comments
*   Hyperlinks
*   Autofilters, advanced filters, pivot tables, conditional formatting, data validation
Password-protected files are not supported and cannot be read by this library.
Quick start:
    import xlrd
    book = xlrd.open_workbook("myfile.xls")
    print("The number of worksheets is {0}".format(book.nsheets))
    print("Worksheet name(s): {0}".format(book.sheet_names()))
    sh = book.sheet_by_index(0)
    print("{0} {1} {2}".format(sh.name, sh.nrows, sh.ncols))
    print("Cell D30 is {0}".format(sh.cell_value(rowx=29, colx=3)))
    for rx in range(sh.nrows):
        print(sh.row(rx))
From the command line, this will show the first, second and last rows of each sheet in each file:
    python PYDIR/scripts/runxlrd.py 3rows *blah*.xls

%prep
%autosetup -n xlrd-2.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-xlrd -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
- Package Spec generated