%global _empty_manifest_terminate_build 0
Name: python-azure-nspkg
Version: 3.0.2
Release: 1
Summary: Microsoft Azure Namespace Package [Internal]
License: MIT License
URL: https://github.com/Azure/azure-sdk-for-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/39/31/b24f494eca22e0389ac2e81b1b734453f187b69c95f039aa202f6f798b84/azure-nspkg-3.0.2.zip
BuildArch: noarch
%description
This is the Microsoft Azure namespace package.
This package is not intended to be installed directly by the end user.
Since version 3.0, this is Python 2 package only, Python 3.x SDKs will use `PEP420 `__ as namespace package strategy.
To avoid issues with package servers that does not support `python_requires`, a Python 3 package is installed but is empty.
It provides the necessary files for other packages to extend the azure namespace.
If you are looking to install the Azure client libraries, see the
`azure `__ bundle package.
%package -n python3-azure-nspkg
Summary: Microsoft Azure Namespace Package [Internal]
Provides: python-azure-nspkg
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-azure-nspkg
This is the Microsoft Azure namespace package.
This package is not intended to be installed directly by the end user.
Since version 3.0, this is Python 2 package only, Python 3.x SDKs will use `PEP420 `__ as namespace package strategy.
To avoid issues with package servers that does not support `python_requires`, a Python 3 package is installed but is empty.
It provides the necessary files for other packages to extend the azure namespace.
If you are looking to install the Azure client libraries, see the
`azure `__ bundle package.
%package help
Summary: Development documents and examples for azure-nspkg
Provides: python3-azure-nspkg-doc
%description help
This is the Microsoft Azure namespace package.
This package is not intended to be installed directly by the end user.
Since version 3.0, this is Python 2 package only, Python 3.x SDKs will use `PEP420 `__ as namespace package strategy.
To avoid issues with package servers that does not support `python_requires`, a Python 3 package is installed but is empty.
It provides the necessary files for other packages to extend the azure namespace.
If you are looking to install the Azure client libraries, see the
`azure `__ bundle package.
%prep
%autosetup -n azure-nspkg-3.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-azure-nspkg -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 3.0.2-1
- Package Spec generated