%global _empty_manifest_terminate_build 0
Name: python-huggingface-hub
Version: 0.13.4
Release: 1
Summary: Client library to download and publish models, datasets and other repos on the huggingface.co hub
License: Apache
URL: https://github.com/huggingface/huggingface_hub
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ef/99/b47e4639754dcc98a4b4b7df370341d8b86b0799d361efe30334907e3be2/huggingface_hub-0.13.4.tar.gz
BuildArch: noarch
Requires: python3-filelock
Requires: python3-requests
Requires: python3-tqdm
Requires: python3-pyyaml
Requires: python3-typing-extensions
Requires: python3-packaging
Requires: python3-importlib-metadata
Requires: python3-InquirerPy
Requires: python3-jedi
Requires: python3-Jinja2
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-env
Requires: python3-pytest-xdist
Requires: python3-soundfile
Requires: python3-Pillow
Requires: python3-black
Requires: python3-ruff
Requires: python3-mypy
Requires: python3-types-PyYAML
Requires: python3-types-requests
Requires: python3-types-simplejson
Requires: python3-types-toml
Requires: python3-types-tqdm
Requires: python3-types-urllib3
Requires: python3-InquirerPy
Requires: python3-InquirerPy
Requires: python3-jedi
Requires: python3-Jinja2
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-env
Requires: python3-pytest-xdist
Requires: python3-soundfile
Requires: python3-Pillow
Requires: python3-black
Requires: python3-ruff
Requires: python3-mypy
Requires: python3-types-PyYAML
Requires: python3-types-requests
Requires: python3-types-simplejson
Requires: python3-types-toml
Requires: python3-types-tqdm
Requires: python3-types-urllib3
Requires: python3-toml
Requires: python3-fastai
Requires: python3-fastcore
Requires: python3-black
Requires: python3-ruff
Requires: python3-mypy
Requires: python3-tensorflow
Requires: python3-pydot
Requires: python3-graphviz
Requires: python3-InquirerPy
Requires: python3-jedi
Requires: python3-Jinja2
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-pytest-env
Requires: python3-pytest-xdist
Requires: python3-soundfile
Requires: python3-Pillow
Requires: python3-torch
Requires: python3-types-PyYAML
Requires: python3-types-requests
Requires: python3-types-simplejson
Requires: python3-types-toml
Requires: python3-types-tqdm
Requires: python3-types-urllib3
%description
# `huggingface_hub`
## Welcome to the huggingface_hub library
The `huggingface_hub` is a client library to interact with the Hugging Face Hub. The Hugging Face Hub is a platform with over 90K models, 14K datasets, and 12K demos in which people can easily collaborate in their ML workflows. The Hub works as a central place where anyone can share, explore, discover, and experiment with open-source Machine Learning.
With `huggingface_hub`, you can easily download and upload models, datasets, and Spaces. You can extract useful information from the Hub, and do much more. Some example use cases:
* Downloading and caching files from a Hub repository.
* Creating repositories and uploading an updated model every few epochs.
* Extract metadata from all models that match certain criteria (e.g. models for `text-classification`).
* List all files from a specific repository.
Read all about it in [the library documentation](https://huggingface.co/docs/huggingface_hub).
## Integrating to the Hub.
We're partnering with cool open source ML libraries to provide free model hosting and versioning. You can find the existing integrations [here](https://huggingface.co/docs/hub/libraries).
The advantages are:
- Free model or dataset hosting for libraries and their users.
- Built-in file versioning, even with very large files, thanks to a git-based approach.
- Hosted inference API for all models publicly available.
- In-browser widgets to play with the uploaded models.
- Anyone can upload a new model for your library, they just need to add the corresponding tag for the model to be discoverable.
- Fast downloads! We use Cloudfront (a CDN) to geo-replicate downloads so they're blazing fast from anywhere on the globe.
- Usage stats and more features to come.
If you would like to integrate your library, feel free to open an issue to begin the discussion. We wrote a [step-by-step guide](https://huggingface.co/docs/hub/adding-a-library) with โค๏ธ showing how to do this integration.
## Feedback (feature requests, bugs, etc.) is super welcome ๐๐๐๐โฅ๏ธ๐งก
%package -n python3-huggingface-hub
Summary: Client library to download and publish models, datasets and other repos on the huggingface.co hub
Provides: python-huggingface-hub
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-huggingface-hub
# `huggingface_hub`
## Welcome to the huggingface_hub library
The `huggingface_hub` is a client library to interact with the Hugging Face Hub. The Hugging Face Hub is a platform with over 90K models, 14K datasets, and 12K demos in which people can easily collaborate in their ML workflows. The Hub works as a central place where anyone can share, explore, discover, and experiment with open-source Machine Learning.
With `huggingface_hub`, you can easily download and upload models, datasets, and Spaces. You can extract useful information from the Hub, and do much more. Some example use cases:
* Downloading and caching files from a Hub repository.
* Creating repositories and uploading an updated model every few epochs.
* Extract metadata from all models that match certain criteria (e.g. models for `text-classification`).
* List all files from a specific repository.
Read all about it in [the library documentation](https://huggingface.co/docs/huggingface_hub).
## Integrating to the Hub.
We're partnering with cool open source ML libraries to provide free model hosting and versioning. You can find the existing integrations [here](https://huggingface.co/docs/hub/libraries).
The advantages are:
- Free model or dataset hosting for libraries and their users.
- Built-in file versioning, even with very large files, thanks to a git-based approach.
- Hosted inference API for all models publicly available.
- In-browser widgets to play with the uploaded models.
- Anyone can upload a new model for your library, they just need to add the corresponding tag for the model to be discoverable.
- Fast downloads! We use Cloudfront (a CDN) to geo-replicate downloads so they're blazing fast from anywhere on the globe.
- Usage stats and more features to come.
If you would like to integrate your library, feel free to open an issue to begin the discussion. We wrote a [step-by-step guide](https://huggingface.co/docs/hub/adding-a-library) with โค๏ธ showing how to do this integration.
## Feedback (feature requests, bugs, etc.) is super welcome ๐๐๐๐โฅ๏ธ๐งก
%package help
Summary: Development documents and examples for huggingface-hub
Provides: python3-huggingface-hub-doc
%description help
# `huggingface_hub`
## Welcome to the huggingface_hub library
The `huggingface_hub` is a client library to interact with the Hugging Face Hub. The Hugging Face Hub is a platform with over 90K models, 14K datasets, and 12K demos in which people can easily collaborate in their ML workflows. The Hub works as a central place where anyone can share, explore, discover, and experiment with open-source Machine Learning.
With `huggingface_hub`, you can easily download and upload models, datasets, and Spaces. You can extract useful information from the Hub, and do much more. Some example use cases:
* Downloading and caching files from a Hub repository.
* Creating repositories and uploading an updated model every few epochs.
* Extract metadata from all models that match certain criteria (e.g. models for `text-classification`).
* List all files from a specific repository.
Read all about it in [the library documentation](https://huggingface.co/docs/huggingface_hub).
## Integrating to the Hub.
We're partnering with cool open source ML libraries to provide free model hosting and versioning. You can find the existing integrations [here](https://huggingface.co/docs/hub/libraries).
The advantages are:
- Free model or dataset hosting for libraries and their users.
- Built-in file versioning, even with very large files, thanks to a git-based approach.
- Hosted inference API for all models publicly available.
- In-browser widgets to play with the uploaded models.
- Anyone can upload a new model for your library, they just need to add the corresponding tag for the model to be discoverable.
- Fast downloads! We use Cloudfront (a CDN) to geo-replicate downloads so they're blazing fast from anywhere on the globe.
- Usage stats and more features to come.
If you would like to integrate your library, feel free to open an issue to begin the discussion. We wrote a [step-by-step guide](https://huggingface.co/docs/hub/adding-a-library) with โค๏ธ showing how to do this integration.
## Feedback (feature requests, bugs, etc.) is super welcome ๐๐๐๐โฅ๏ธ๐งก
%prep
%autosetup -n huggingface-hub-0.13.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-huggingface-hub -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.13.4-1
- Package Spec generated