%global _empty_manifest_terminate_build 0
Name: python-BenBotAsync
Version: 3.0.2
Release: 1
Summary: Asynchronous Python wrapper for BenBot API.
License: MIT License
URL: https://github.com/xMistt/BenBot
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5e/40/c14e1954385d4d97b04f983b4d93e3e9d39444e403f4c7c16c3895ef699e/BenBotAsync-3.0.2.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
%description
# BenBotAsync
Python wrapper for the BenBot API.
[![Downloads](https://pepy.tech/badge/benbotasync)](https://pepy.tech/project/benbotasync)
[![Requires: Python 3.x](https://img.shields.io/pypi/pyversions/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
[![BenBot Version: 1.0.1](https://img.shields.io/pypi/v/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
## Installing:
### ~~Synchronous~~: **Deprecated, use the async version.**
~~Windows:~~ ``py -3 -m pip install BenBot``
~~Linux/macOS:~~ ``python3 -m pip install BenBot``
### Asynchronous:
Windows: ``py -3 -m pip install BenBotAsync``
Linux/macOS: ``python3 -m pip install BenBotAsync``
## Examples:
```py
import BenBotAsync
import asyncio
async def ben_search():
result = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="full",
name="Ghoul Trooper"
)
print(result.id)
loop = asyncio.get_event_loop()
loop.run_until_complete(ben_search())
```
This would output:
```CID_029_Athena_Commando_F_Halloween```
fortnitepy example:
```py
import fortnitepy
import BenBotAsync
client = fortnitepy.Client(
auth=fortnitepy.EmailAndPasswordAuth(
email='example@email.com',
password='password123'
)
)
@client.event
async def event_friend_message(message: fortnitepy.FriendMessage) -> None:
args = message.content.split()
split = args[1:]
content = " ".join(split)
if args[0] == '!skin':
skin = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="contains",
name=content,
backendType="AthenaCharacter"
)
await client.user.party.me.set_outfit(asset=skin.id)
client.run()
```
You can check out the documentation for BenBotAsync [here](https://stoplight.io/p/docs/gh/xMistt/BenBotAsync).
%package -n python3-BenBotAsync
Summary: Asynchronous Python wrapper for BenBot API.
Provides: python-BenBotAsync
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-BenBotAsync
# BenBotAsync
Python wrapper for the BenBot API.
[![Downloads](https://pepy.tech/badge/benbotasync)](https://pepy.tech/project/benbotasync)
[![Requires: Python 3.x](https://img.shields.io/pypi/pyversions/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
[![BenBot Version: 1.0.1](https://img.shields.io/pypi/v/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
## Installing:
### ~~Synchronous~~: **Deprecated, use the async version.**
~~Windows:~~ ``py -3 -m pip install BenBot``
~~Linux/macOS:~~ ``python3 -m pip install BenBot``
### Asynchronous:
Windows: ``py -3 -m pip install BenBotAsync``
Linux/macOS: ``python3 -m pip install BenBotAsync``
## Examples:
```py
import BenBotAsync
import asyncio
async def ben_search():
result = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="full",
name="Ghoul Trooper"
)
print(result.id)
loop = asyncio.get_event_loop()
loop.run_until_complete(ben_search())
```
This would output:
```CID_029_Athena_Commando_F_Halloween```
fortnitepy example:
```py
import fortnitepy
import BenBotAsync
client = fortnitepy.Client(
auth=fortnitepy.EmailAndPasswordAuth(
email='example@email.com',
password='password123'
)
)
@client.event
async def event_friend_message(message: fortnitepy.FriendMessage) -> None:
args = message.content.split()
split = args[1:]
content = " ".join(split)
if args[0] == '!skin':
skin = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="contains",
name=content,
backendType="AthenaCharacter"
)
await client.user.party.me.set_outfit(asset=skin.id)
client.run()
```
You can check out the documentation for BenBotAsync [here](https://stoplight.io/p/docs/gh/xMistt/BenBotAsync).
%package help
Summary: Development documents and examples for BenBotAsync
Provides: python3-BenBotAsync-doc
%description help
# BenBotAsync
Python wrapper for the BenBot API.
[![Downloads](https://pepy.tech/badge/benbotasync)](https://pepy.tech/project/benbotasync)
[![Requires: Python 3.x](https://img.shields.io/pypi/pyversions/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
[![BenBot Version: 1.0.1](https://img.shields.io/pypi/v/BenBotAsync.svg)](https://pypi.org/project/BenBotAsync/)
## Installing:
### ~~Synchronous~~: **Deprecated, use the async version.**
~~Windows:~~ ``py -3 -m pip install BenBot``
~~Linux/macOS:~~ ``python3 -m pip install BenBot``
### Asynchronous:
Windows: ``py -3 -m pip install BenBotAsync``
Linux/macOS: ``python3 -m pip install BenBotAsync``
## Examples:
```py
import BenBotAsync
import asyncio
async def ben_search():
result = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="full",
name="Ghoul Trooper"
)
print(result.id)
loop = asyncio.get_event_loop()
loop.run_until_complete(ben_search())
```
This would output:
```CID_029_Athena_Commando_F_Halloween```
fortnitepy example:
```py
import fortnitepy
import BenBotAsync
client = fortnitepy.Client(
auth=fortnitepy.EmailAndPasswordAuth(
email='example@email.com',
password='password123'
)
)
@client.event
async def event_friend_message(message: fortnitepy.FriendMessage) -> None:
args = message.content.split()
split = args[1:]
content = " ".join(split)
if args[0] == '!skin':
skin = await BenBotAsync.get_cosmetic(
lang="en",
searchLang="en",
matchMethod="contains",
name=content,
backendType="AthenaCharacter"
)
await client.user.party.me.set_outfit(asset=skin.id)
client.run()
```
You can check out the documentation for BenBotAsync [here](https://stoplight.io/p/docs/gh/xMistt/BenBotAsync).
%prep
%autosetup -n BenBotAsync-3.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-BenBotAsync -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 3.0.2-1
- Package Spec generated