%global _empty_manifest_terminate_build 0
Name:		python-folium
Version:	0.14.0
Release:	1
Summary:	Make beautiful maps with Leaflet.js & Python
License:	MIT
URL:		https://github.com/python-visualization/folium
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/bb/d0/2d8d1a500d829caa0e6b394ee933344f7fee81cb685409e5aaf5c9492f64/folium-0.14.0.tar.gz
BuildArch:	noarch

Requires:	python3-branca
Requires:	python3-jinja2
Requires:	python3-numpy
Requires:	python3-requests
Requires:	python3-pytest

%description
|folium|
Python Data, Leaflet.js Maps
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
`folium` builds on the data wrangling strengths of the Python ecosystem and the
mapping strengths of the Leaflet.js library. Manipulate your data in Python,
then visualize it in a Leaflet map via `folium`.

%package -n python3-folium
Summary:	Make beautiful maps with Leaflet.js & Python
Provides:	python-folium
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-folium
|folium|
Python Data, Leaflet.js Maps
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
`folium` builds on the data wrangling strengths of the Python ecosystem and the
mapping strengths of the Leaflet.js library. Manipulate your data in Python,
then visualize it in a Leaflet map via `folium`.

%package help
Summary:	Development documents and examples for folium
Provides:	python3-folium-doc
%description help
|folium|
Python Data, Leaflet.js Maps
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
`folium` builds on the data wrangling strengths of the Python ecosystem and the
mapping strengths of the Leaflet.js library. Manipulate your data in Python,
then visualize it in a Leaflet map via `folium`.

%prep
%autosetup -n folium-0.14.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-folium -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.0-1
- Package Spec generated