%global _empty_manifest_terminate_build 0
Name: python-osqp
Version: 0.6.2.post8
Release: 1
Summary: OSQP: The Operator Splitting QP Solver
License: Apache 2.0
URL: https://osqp.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5a/61/7b94eb7de2b7c9d12d8757ef9d0f5dfe3c5dc0ba0e88f08d4ae929996a34/osqp-0.6.2.post8.tar.gz
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-qdldl
%description
Python wrapper for `OSQP `__: the Operator
Splitting QP Solver.
The OSQP (Operator Splitting Quadratic Program) solver is a numerical
optimization package for solving problems in the form
minimize 0.5 x' P x + q' x
subject to l <= A x <= u
where ``x in R^n`` is the optimization variable. The objective function
is defined by a positive semidefinite matrix ``P in S^n_+`` and vector
``q in R^n``. The linear constraints are defined by matrix
``A in R^{m x n}`` and vectors ``l in R^m U {-inf}^m``,
``u in R^m U {+inf}^m``.
%package -n python3-osqp
Summary: OSQP: The Operator Splitting QP Solver
Provides: python-osqp
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-osqp
Python wrapper for `OSQP `__: the Operator
Splitting QP Solver.
The OSQP (Operator Splitting Quadratic Program) solver is a numerical
optimization package for solving problems in the form
minimize 0.5 x' P x + q' x
subject to l <= A x <= u
where ``x in R^n`` is the optimization variable. The objective function
is defined by a positive semidefinite matrix ``P in S^n_+`` and vector
``q in R^n``. The linear constraints are defined by matrix
``A in R^{m x n}`` and vectors ``l in R^m U {-inf}^m``,
``u in R^m U {+inf}^m``.
%package help
Summary: Development documents and examples for osqp
Provides: python3-osqp-doc
%description help
Python wrapper for `OSQP `__: the Operator
Splitting QP Solver.
The OSQP (Operator Splitting Quadratic Program) solver is a numerical
optimization package for solving problems in the form
minimize 0.5 x' P x + q' x
subject to l <= A x <= u
where ``x in R^n`` is the optimization variable. The objective function
is defined by a positive semidefinite matrix ``P in S^n_+`` and vector
``q in R^n``. The linear constraints are defined by matrix
``A in R^{m x n}`` and vectors ``l in R^m U {-inf}^m``,
``u in R^m U {+inf}^m``.
%prep
%autosetup -n osqp-0.6.2.post8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-osqp -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.6.2.post8-1
- Package Spec generated