%global _empty_manifest_terminate_build 0
Name:		python-face
Version:	22.0.0
Release:	1
Summary:	A command-line application framework (and CLI parser). Friendly for users, full-featured for developers.
License:	BSD
URL:		https://github.com/mahmoud/face
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d7/bc/4d0f6c1e095eb977782edd94245f84b69c6f8df152480c78ab310e895098/face-22.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-boltons

%description
A command-line interface parser and framework, friendly for users,
full-featured for developers.


%package -n python3-face
Summary:	A command-line application framework (and CLI parser). Friendly for users, full-featured for developers.
Provides:	python-face
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-face
A command-line interface parser and framework, friendly for users,
full-featured for developers.


%package help
Summary:	Development documents and examples for face
Provides:	python3-face-doc
%description help
A command-line interface parser and framework, friendly for users,
full-featured for developers.


%prep
%autosetup -n face-22.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-face -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 22.0.0-1
- Package Spec generated