%global _empty_manifest_terminate_build 0
Name: python-apache-airflow-providers-amazon
Version: 7.4.0
Release: 1
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-amazon package
License: Apache License 2.0
URL: https://airflow.apache.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/7a/848d502a813520740a3067d64bf5fc530b58c0bfb511bc26be96b883b645/apache-airflow-providers-amazon-7.4.0.tar.gz
BuildArch: noarch
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow
Requires: python3-asgiref
Requires: python3-boto3
Requires: python3-jsonpath-ng
Requires: python3-mypy-boto3-appflow
Requires: python3-mypy-boto3-rds
Requires: python3-mypy-boto3-redshift-data
Requires: python3-redshift-connector
Requires: python3-sqlalchemy-redshift
Requires: python3-watchtower
Requires: python3-aiobotocore
Requires: python3-apache-airflow-providers-apache-hive
Requires: python3-apache-airflow-providers-cncf-kubernetes
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow-providers-exasol
Requires: python3-apache-airflow-providers-ftp
Requires: python3-apache-airflow-providers-google
Requires: python3-apache-airflow-providers-imap
Requires: python3-apache-airflow-providers-mongo
Requires: python3-pandas
Requires: python3-apache-airflow-providers-salesforce
Requires: python3-apache-airflow-providers-ssh
%description
This is a provider package for ``amazon`` provider. All classes for this provider package
are in ``airflow.providers.amazon`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package -n python3-apache-airflow-providers-amazon
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-amazon package
Provides: python-apache-airflow-providers-amazon
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-apache-airflow-providers-amazon
This is a provider package for ``amazon`` provider. All classes for this provider package
are in ``airflow.providers.amazon`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package help
Summary: Development documents and examples for apache-airflow-providers-amazon
Provides: python3-apache-airflow-providers-amazon-doc
%description help
This is a provider package for ``amazon`` provider. All classes for this provider package
are in ``airflow.providers.amazon`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%prep
%autosetup -n apache-airflow-providers-amazon-7.4.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-apache-airflow-providers-amazon -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 7.4.0-1
- Package Spec generated