%global _empty_manifest_terminate_build 0
Name:		python-okta
Version:	2.9.2
Release:	1
Summary:	Python SDK for the Okta Management API
License:	Apache License 2.0
URL:		https://github.com/okta/okta-sdk-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4f/7b/85f138f136b4933d702d0ec3a1bab94c8f5e1dff177fabd051d2e60835ca/okta-2.9.2.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-flatdict
Requires:	python3-pyyaml
Requires:	python3-xmltodict
Requires:	python3-yarl
Requires:	python3-pycryptodomex
Requires:	python3-jose
Requires:	python3-aenum
Requires:	python3-pydash

%description
A Python library for the Okta Management APIs.

%package -n python3-okta
Summary:	Python SDK for the Okta Management API
Provides:	python-okta
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-okta
A Python library for the Okta Management APIs.

%package help
Summary:	Development documents and examples for okta
Provides:	python3-okta-doc
%description help
A Python library for the Okta Management APIs.

%prep
%autosetup -n okta-2.9.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-okta -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.9.2-1
- Package Spec generated