%global _empty_manifest_terminate_build 0
Name: python-fs-s3fs
Version: 1.1.1
Release: 1
Summary: Amazon S3 filesystem for PyFilesystem2
License: MIT
URL: https://github.com/PyFilesystem/s3fs
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/f1/b641963f8694cdf7c3daed0276fef361c2b51717bf5f3e8a89b63c8ba237/fs-s3fs-1.1.1.tar.gz
BuildArch: noarch
%description
S3FS is a `PyFilesystem `__ interface to
Amazon S3 cloud storage.
As a PyFilesystem concrete class,
`S3FS `__ allows you to work
with S3 in the same way as any other supported filesystem.
%package -n python3-fs-s3fs
Summary: Amazon S3 filesystem for PyFilesystem2
Provides: python-fs-s3fs
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fs-s3fs
S3FS is a `PyFilesystem `__ interface to
Amazon S3 cloud storage.
As a PyFilesystem concrete class,
`S3FS `__ allows you to work
with S3 in the same way as any other supported filesystem.
%package help
Summary: Development documents and examples for fs-s3fs
Provides: python3-fs-s3fs-doc
%description help
S3FS is a `PyFilesystem `__ interface to
Amazon S3 cloud storage.
As a PyFilesystem concrete class,
`S3FS `__ allows you to work
with S3 in the same way as any other supported filesystem.
%prep
%autosetup -n fs-s3fs-1.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fs-s3fs -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.1.1-1
- Package Spec generated