%global _empty_manifest_terminate_build 0
Name:		python-pylibftdi
Version:	0.20.0
Release:	1
Summary:	Pythonic interface to FTDI devices using libftdi
License:	MIT License
URL:		https://github.com/codedstructure/pylibftdi
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b8/03/4f778ce6dceea58dc5bfd555c22fdb265afc922d81d3c4496a791a54c479/pylibftdi-0.20.0.tar.gz
BuildArch:	noarch


%description
pylibftdi is a minimal Pythonic interface to FTDI devices using libftdi_.
 - No dependencies beyond standard library and a `libftdi` install.
 - Supports parallel and serial devices
 - Support for multiple devices
 - File-like interface wherever appropriate
 - Cross-platform
 - The API might change prior to reaching a 1.0 release.

%package -n python3-pylibftdi
Summary:	Pythonic interface to FTDI devices using libftdi
Provides:	python-pylibftdi
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pylibftdi
pylibftdi is a minimal Pythonic interface to FTDI devices using libftdi_.
 - No dependencies beyond standard library and a `libftdi` install.
 - Supports parallel and serial devices
 - Support for multiple devices
 - File-like interface wherever appropriate
 - Cross-platform
 - The API might change prior to reaching a 1.0 release.

%package help
Summary:	Development documents and examples for pylibftdi
Provides:	python3-pylibftdi-doc
%description help
pylibftdi is a minimal Pythonic interface to FTDI devices using libftdi_.
 - No dependencies beyond standard library and a `libftdi` install.
 - Supports parallel and serial devices
 - Support for multiple devices
 - File-like interface wherever appropriate
 - Cross-platform
 - The API might change prior to reaching a 1.0 release.

%prep
%autosetup -n pylibftdi-0.20.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pylibftdi -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.20.0-1
- Package Spec generated