%global _empty_manifest_terminate_build 0
Name: python-teamcity-messages
Version: 1.32
Release: 1
Summary: Send test results to TeamCity continuous integration server from unittest, nose, py.test, twisted trial, behave (Python 2.6+)
License: Apache 2.0
URL: https://github.com/JetBrains/teamcity-messages
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/f3/6d8eac4e4ed39855a902672cac33a2441f2c3942a9730f93b3c1025d4e21/teamcity-messages-1.32.tar.gz
BuildArch: noarch
%description
| |jb_project| |license| |pypi_version|
| |versions| |teamcity_ci|
This package integrates Python with the
`TeamCity `__ Continuous Integration
(CI) server. It allows sending `"service
messages" `__
from Python code. Additionally, it provides integration with the
following testing frameworks and tools:
- `py.test `__
- `nose `__
- `Django `__
- `unittest (Python standard
library) `__
- `Trial (Twisted) `__
- `Flake8 `__
- `Behave `__
- `PyLint `__
%package -n python3-teamcity-messages
Summary: Send test results to TeamCity continuous integration server from unittest, nose, py.test, twisted trial, behave (Python 2.6+)
Provides: python-teamcity-messages
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-teamcity-messages
| |jb_project| |license| |pypi_version|
| |versions| |teamcity_ci|
This package integrates Python with the
`TeamCity `__ Continuous Integration
(CI) server. It allows sending `"service
messages" `__
from Python code. Additionally, it provides integration with the
following testing frameworks and tools:
- `py.test `__
- `nose `__
- `Django `__
- `unittest (Python standard
library) `__
- `Trial (Twisted) `__
- `Flake8 `__
- `Behave `__
- `PyLint `__
%package help
Summary: Development documents and examples for teamcity-messages
Provides: python3-teamcity-messages-doc
%description help
| |jb_project| |license| |pypi_version|
| |versions| |teamcity_ci|
This package integrates Python with the
`TeamCity `__ Continuous Integration
(CI) server. It allows sending `"service
messages" `__
from Python code. Additionally, it provides integration with the
following testing frameworks and tools:
- `py.test `__
- `nose `__
- `Django `__
- `unittest (Python standard
library) `__
- `Trial (Twisted) `__
- `Flake8 `__
- `Behave `__
- `PyLint `__
%prep
%autosetup -n teamcity-messages-1.32
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-teamcity-messages -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.32-1
- Package Spec generated