%global _empty_manifest_terminate_build 0
Name:		python-cronex
Version:	0.1.3.1
Release:	1
Summary:	This module provides an easy to use interface for cron-like task scheduling.
License:	MIT
URL:		https://github.com/ericpruitt/cronex
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ed/e9/419305235dd2f2b2038b6746cb57d32b3a5ebc0ef9600bdfd46d6da87232/cronex-0.1.3.1.tar.gz
BuildArch:	noarch


%description
This module provides an easy to use interface for cron-like task
scheduling. The cron expression evaluation implemented by this library
is 100% Vixie Cron compatible and also supports `Java
Quartz's <http://www.quartz-scheduler.org/documentation/quartz-1.x/tutorials/crontrigger>`__
non-standard "L", "W" and "#" characters.
One other useful feature this library provides is the ability to set
triggers at arbitrary intervals such as every 9 hours, every 11 minutes,
etc., without the issues caused by using asterisk-slash notation; using
``*/9`` in the hours field of most cron implementations would result in
a trigger firing at 9:XX AM at 6:XX PM each day, but with
CronExpresssions, the trigger would fire at 9:XX AM, 6:XX PM then, on
the following day 3:XX AM, 12:XX PM, 9:XX PM and so.

%package -n python3-cronex
Summary:	This module provides an easy to use interface for cron-like task scheduling.
Provides:	python-cronex
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-cronex
This module provides an easy to use interface for cron-like task
scheduling. The cron expression evaluation implemented by this library
is 100% Vixie Cron compatible and also supports `Java
Quartz's <http://www.quartz-scheduler.org/documentation/quartz-1.x/tutorials/crontrigger>`__
non-standard "L", "W" and "#" characters.
One other useful feature this library provides is the ability to set
triggers at arbitrary intervals such as every 9 hours, every 11 minutes,
etc., without the issues caused by using asterisk-slash notation; using
``*/9`` in the hours field of most cron implementations would result in
a trigger firing at 9:XX AM at 6:XX PM each day, but with
CronExpresssions, the trigger would fire at 9:XX AM, 6:XX PM then, on
the following day 3:XX AM, 12:XX PM, 9:XX PM and so.

%package help
Summary:	Development documents and examples for cronex
Provides:	python3-cronex-doc
%description help
This module provides an easy to use interface for cron-like task
scheduling. The cron expression evaluation implemented by this library
is 100% Vixie Cron compatible and also supports `Java
Quartz's <http://www.quartz-scheduler.org/documentation/quartz-1.x/tutorials/crontrigger>`__
non-standard "L", "W" and "#" characters.
One other useful feature this library provides is the ability to set
triggers at arbitrary intervals such as every 9 hours, every 11 minutes,
etc., without the issues caused by using asterisk-slash notation; using
``*/9`` in the hours field of most cron implementations would result in
a trigger firing at 9:XX AM at 6:XX PM each day, but with
CronExpresssions, the trigger would fire at 9:XX AM, 6:XX PM then, on
the following day 3:XX AM, 12:XX PM, 9:XX PM and so.

%prep
%autosetup -n cronex-0.1.3.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-cronex -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.3.1-1
- Package Spec generated