%global _empty_manifest_terminate_build 0
Name: python-rpqueue
Version: 0.33.4
Release: 1
Summary: Use Redis as a priority-enabled and time-based task queue.
License: GNU LGPL v2.1
URL: https://github.com/josiahcarlson/rpqueue
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9f/32/47bb400696ffe8d49f1b71631a511434e9cb9e79994d35ad2f7c5db5773b/rpqueue-0.33.4.tar.gz
BuildArch: noarch
%description
This package intends to offer a priority-based remote task queue solution
using Redis as the transport and persistence layer, and JSON for a common
interchange format.
Semantically, this module implements a 0/1 or 1+ queue with optional retries.
That is, it attempts to execute every task once by default, or >1 manually, or
>1 automatically with 'visibility timeouts'.
If a 'manual' retry task raises an exception, it will not automatically retry,
but you can manually retry the task and specify the maximum attempts. Similarly,
for tasks with visibility timeouts, if the task rasises an exception or doesn't
complete, it will be retried up to the limit of retries provided.
See the `Retries`_ section below.
Full documentation is available: `https://josiahcarlson.github.io/rpqueue/
`_
%package -n python3-rpqueue
Summary: Use Redis as a priority-enabled and time-based task queue.
Provides: python-rpqueue
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-rpqueue
This package intends to offer a priority-based remote task queue solution
using Redis as the transport and persistence layer, and JSON for a common
interchange format.
Semantically, this module implements a 0/1 or 1+ queue with optional retries.
That is, it attempts to execute every task once by default, or >1 manually, or
>1 automatically with 'visibility timeouts'.
If a 'manual' retry task raises an exception, it will not automatically retry,
but you can manually retry the task and specify the maximum attempts. Similarly,
for tasks with visibility timeouts, if the task rasises an exception or doesn't
complete, it will be retried up to the limit of retries provided.
See the `Retries`_ section below.
Full documentation is available: `https://josiahcarlson.github.io/rpqueue/
`_
%package help
Summary: Development documents and examples for rpqueue
Provides: python3-rpqueue-doc
%description help
This package intends to offer a priority-based remote task queue solution
using Redis as the transport and persistence layer, and JSON for a common
interchange format.
Semantically, this module implements a 0/1 or 1+ queue with optional retries.
That is, it attempts to execute every task once by default, or >1 manually, or
>1 automatically with 'visibility timeouts'.
If a 'manual' retry task raises an exception, it will not automatically retry,
but you can manually retry the task and specify the maximum attempts. Similarly,
for tasks with visibility timeouts, if the task rasises an exception or doesn't
complete, it will be retried up to the limit of retries provided.
See the `Retries`_ section below.
Full documentation is available: `https://josiahcarlson.github.io/rpqueue/
`_
%prep
%autosetup -n rpqueue-0.33.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-rpqueue -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.33.4-1
- Package Spec generated