%global _empty_manifest_terminate_build 0
Name:		python-sqlparams
Version:	5.1.0
Release:	1
Summary:	Convert between various DB API 2.0 parameter styles.
License:	MIT License
URL:		https://pypi.org/project/sqlparams/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/d8/de/b5ece7f79dae9442f145c8011d39fa80dda24be8a61e83c998f1fe5a1f7f/sqlparams-5.1.0.tar.gz
BuildArch:	noarch


%description
*sqlparams* is a utility package for converting between various SQL
parameter styles. This can simplify the use of SQL parameters in queries by
allowing the use of named parameters where only ordinal are supported. Some
`Python DB API 2.0`_ compliant modules only support the ordinal *qmark* or
*format* style parameters (e.g., `pyodbc`_ only supports *qmark*). This
package provides a helper class, `SQLParams`_, that is used to convert
from any parameter style (*qmark*, *numeric*, *named*, *format*, *pyformat*;
and the non-standard *numeric_dollar* and *named_dollar*), and have them
safely converted to the desired parameter style.

%package -n python3-sqlparams
Summary:	Convert between various DB API 2.0 parameter styles.
Provides:	python-sqlparams
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sqlparams
*sqlparams* is a utility package for converting between various SQL
parameter styles. This can simplify the use of SQL parameters in queries by
allowing the use of named parameters where only ordinal are supported. Some
`Python DB API 2.0`_ compliant modules only support the ordinal *qmark* or
*format* style parameters (e.g., `pyodbc`_ only supports *qmark*). This
package provides a helper class, `SQLParams`_, that is used to convert
from any parameter style (*qmark*, *numeric*, *named*, *format*, *pyformat*;
and the non-standard *numeric_dollar* and *named_dollar*), and have them
safely converted to the desired parameter style.

%package help
Summary:	Development documents and examples for sqlparams
Provides:	python3-sqlparams-doc
%description help
*sqlparams* is a utility package for converting between various SQL
parameter styles. This can simplify the use of SQL parameters in queries by
allowing the use of named parameters where only ordinal are supported. Some
`Python DB API 2.0`_ compliant modules only support the ordinal *qmark* or
*format* style parameters (e.g., `pyodbc`_ only supports *qmark*). This
package provides a helper class, `SQLParams`_, that is used to convert
from any parameter style (*qmark*, *numeric*, *named*, *format*, *pyformat*;
and the non-standard *numeric_dollar* and *named_dollar*), and have them
safely converted to the desired parameter style.

%prep
%autosetup -n sqlparams-5.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sqlparams -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 5.1.0-1
- Package Spec generated