%global _empty_manifest_terminate_build 0
Name:		python-pyecharts
Version:	2.0.3
Release:	1
Summary:	Python options, make charting easier
License:	MIT
URL:		https://github.com/pyecharts/pyecharts
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/26/d6/013a1be22a0dc419566d6bd1b6fa019afc30377205816f76494a30846042/pyecharts-2.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-jinja2
Requires:	python3-prettytable
Requires:	python3-simplejson
Requires:	python3-PIL
Requires:	python3-snapshot-phantomjs
Requires:	python3-snapshot-pyppeteer
Requires:	python3-snapshot-selenium

%description


%package -n python3-pyecharts
Summary:	Python options, make charting easier
Provides:	python-pyecharts
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pyecharts


%package help
Summary:	Development documents and examples for pyecharts
Provides:	python3-pyecharts-doc
%description help


%prep
%autosetup -n pyecharts-2.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pyecharts -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.3-1
- Package Spec generated