%global _empty_manifest_terminate_build 0
Name:		python-dj-static
Version:	0.0.6
Release:	1
Summary:	Serve production static files with Django.
License:	BSD
URL:		https://github.com/kennethreitz/dj-static
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/2b/8f/77a4b8ec50c821193bf9682c7896f12fd0418eb3711a7d66796ede59c23b/dj-static-0.0.6.tar.gz
BuildArch:	noarch


%description
Configure your static assets in ``settings.py``::
   STATIC_ROOT = 'staticfiles'
   STATIC_URL = '/static/'
Then, update your ``wsgi.py`` file to use dj-static::
    from django.core.wsgi import get_wsgi_application
    from dj_static import Cling
    application = Cling(get_wsgi_application())

%package -n python3-dj-static
Summary:	Serve production static files with Django.
Provides:	python-dj-static
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dj-static
Configure your static assets in ``settings.py``::
   STATIC_ROOT = 'staticfiles'
   STATIC_URL = '/static/'
Then, update your ``wsgi.py`` file to use dj-static::
    from django.core.wsgi import get_wsgi_application
    from dj_static import Cling
    application = Cling(get_wsgi_application())

%package help
Summary:	Development documents and examples for dj-static
Provides:	python3-dj-static-doc
%description help
Configure your static assets in ``settings.py``::
   STATIC_ROOT = 'staticfiles'
   STATIC_URL = '/static/'
Then, update your ``wsgi.py`` file to use dj-static::
    from django.core.wsgi import get_wsgi_application
    from dj_static import Cling
    application = Cling(get_wsgi_application())

%prep
%autosetup -n dj-static-0.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dj-static -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.6-1
- Package Spec generated