%global _empty_manifest_terminate_build 0
Name: python-mariadb
Version: 1.1.6
Release: 1
Summary: Python MariaDB extension
License: LGPL 2.1
URL: https://www.github.com/mariadb-corporation/mariadb-connector-python
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/f4/b93c582407689432927959c452321eb50ff027e878b09506b5a070bcd3f0/mariadb-1.1.6.tar.gz
Requires: python3-packaging
%description
# MariaDB Connector/Python
[![License (LGPL version 2.1)][licence-image]](LICENSE)
[![Python 3.7][python-image]][python-url]
[![Build Status](https://travis-ci.com/mariadb-corporation/mariadb-connector-python.svg?branch=1.1)](https://app.travis-ci.com/mariadb-corporation/mariadb-connector-python)
MariaDB Connector/Python enables python programs to access MariaDB and MySQL databases, using an API
which is compliant with the Python DB API 2.0 (PEP-249). It is written in C and uses MariaDB Connector/C
client library for client server communication.
## License
MariaDB Connector/Python is licensed under the LGPL 2.1
## Source code
MariaDB Connector/Python source code is hosted on [Github](https://github.com/mariadb-corporation/mariadb-connector-python)
## Documentation
MariaDB Connector/Python documentation can be found on [Github Pages](https://mariadb-corporation.github.io/mariadb-connector-python/)
## Bugs
Bugs and feature requests should be filed in the [MariaDB bug ticket system](https://jira.mariadb.org/)
[licence-image]:https://img.shields.io/badge/license-GNU%20LGPL%20version%202.1-green.svg?style=flat-square
[python-image]:https://img.shields.io/badge/python-3.7-blue.svg
[python-url]:https://www.python.org/downloads/release/python-370/
%package -n python3-mariadb
Summary: Python MariaDB extension
Provides: python-mariadb
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-mariadb
# MariaDB Connector/Python
[![License (LGPL version 2.1)][licence-image]](LICENSE)
[![Python 3.7][python-image]][python-url]
[![Build Status](https://travis-ci.com/mariadb-corporation/mariadb-connector-python.svg?branch=1.1)](https://app.travis-ci.com/mariadb-corporation/mariadb-connector-python)
MariaDB Connector/Python enables python programs to access MariaDB and MySQL databases, using an API
which is compliant with the Python DB API 2.0 (PEP-249). It is written in C and uses MariaDB Connector/C
client library for client server communication.
## License
MariaDB Connector/Python is licensed under the LGPL 2.1
## Source code
MariaDB Connector/Python source code is hosted on [Github](https://github.com/mariadb-corporation/mariadb-connector-python)
## Documentation
MariaDB Connector/Python documentation can be found on [Github Pages](https://mariadb-corporation.github.io/mariadb-connector-python/)
## Bugs
Bugs and feature requests should be filed in the [MariaDB bug ticket system](https://jira.mariadb.org/)
[licence-image]:https://img.shields.io/badge/license-GNU%20LGPL%20version%202.1-green.svg?style=flat-square
[python-image]:https://img.shields.io/badge/python-3.7-blue.svg
[python-url]:https://www.python.org/downloads/release/python-370/
%package help
Summary: Development documents and examples for mariadb
Provides: python3-mariadb-doc
%description help
# MariaDB Connector/Python
[![License (LGPL version 2.1)][licence-image]](LICENSE)
[![Python 3.7][python-image]][python-url]
[![Build Status](https://travis-ci.com/mariadb-corporation/mariadb-connector-python.svg?branch=1.1)](https://app.travis-ci.com/mariadb-corporation/mariadb-connector-python)
MariaDB Connector/Python enables python programs to access MariaDB and MySQL databases, using an API
which is compliant with the Python DB API 2.0 (PEP-249). It is written in C and uses MariaDB Connector/C
client library for client server communication.
## License
MariaDB Connector/Python is licensed under the LGPL 2.1
## Source code
MariaDB Connector/Python source code is hosted on [Github](https://github.com/mariadb-corporation/mariadb-connector-python)
## Documentation
MariaDB Connector/Python documentation can be found on [Github Pages](https://mariadb-corporation.github.io/mariadb-connector-python/)
## Bugs
Bugs and feature requests should be filed in the [MariaDB bug ticket system](https://jira.mariadb.org/)
[licence-image]:https://img.shields.io/badge/license-GNU%20LGPL%20version%202.1-green.svg?style=flat-square
[python-image]:https://img.shields.io/badge/python-3.7-blue.svg
[python-url]:https://www.python.org/downloads/release/python-370/
%prep
%autosetup -n mariadb-1.1.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mariadb -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.1.6-1
- Package Spec generated