%global _empty_manifest_terminate_build 0
Name: python-docplex
Version: 2.25.236
Release: 1
Summary: The IBM Decision Optimization CPLEX Modeling for Python
License: Apache 2.0
URL: https://www.ibm.com/cloud/decision-optimization-for-watson-studio
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/bc/c07cf1ef44826d16e96d8c86d35e3120c64a27126baa36f9d36c5c1c9423/docplex-2.25.236.tar.gz
BuildArch: noarch
%description
Welcome to the IBM Decision Optimization CPLEX Modeling for Python.
Licensed under the Apache License v2.0.
With this library, you can quickly and easily add the power of optimization to
your application. You need IBM ILOG CPLEX Optimization Studio to solve the models.
This library is composed of 2 modules:
* IBM Decision Optimization CPLEX Optimizer Modeling for Python - with namespace docplex.mp
* IBM Decision Optimization CP Optimizer Modeling for Python - with namespace docplex.cp
Solving with CPLEX locally requires that IBM ILOG CPLEX Optimization Studio V12.8 or later
is installed on your machine.
This library is `numpy` friendly.
`Documentation `_
`Examples `_
%package -n python3-docplex
Summary: The IBM Decision Optimization CPLEX Modeling for Python
Provides: python-docplex
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-docplex
Welcome to the IBM Decision Optimization CPLEX Modeling for Python.
Licensed under the Apache License v2.0.
With this library, you can quickly and easily add the power of optimization to
your application. You need IBM ILOG CPLEX Optimization Studio to solve the models.
This library is composed of 2 modules:
* IBM Decision Optimization CPLEX Optimizer Modeling for Python - with namespace docplex.mp
* IBM Decision Optimization CP Optimizer Modeling for Python - with namespace docplex.cp
Solving with CPLEX locally requires that IBM ILOG CPLEX Optimization Studio V12.8 or later
is installed on your machine.
This library is `numpy` friendly.
`Documentation `_
`Examples `_
%package help
Summary: Development documents and examples for docplex
Provides: python3-docplex-doc
%description help
Welcome to the IBM Decision Optimization CPLEX Modeling for Python.
Licensed under the Apache License v2.0.
With this library, you can quickly and easily add the power of optimization to
your application. You need IBM ILOG CPLEX Optimization Studio to solve the models.
This library is composed of 2 modules:
* IBM Decision Optimization CPLEX Optimizer Modeling for Python - with namespace docplex.mp
* IBM Decision Optimization CP Optimizer Modeling for Python - with namespace docplex.cp
Solving with CPLEX locally requires that IBM ILOG CPLEX Optimization Studio V12.8 or later
is installed on your machine.
This library is `numpy` friendly.
`Documentation `_
`Examples `_
%prep
%autosetup -n docplex-2.25.236
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-docplex -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 2.25.236-1
- Package Spec generated