%global _empty_manifest_terminate_build 0
Name:		python-ais-dom
Version:	2023.3.2
Release:	1
Summary:	Open-source home automation platform running on Python 3.
License:	Apache-2.0
URL:		https://www.home-assistant.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/77/2d/5b57bdc36fb1899e02f615a47bd92d660acf18ffc81eadb283a6deef9aa1/ais-dom-2023.3.2.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-astral
Requires:	python3-async-timeout
Requires:	python3-attrs
Requires:	python3-atomicwrites-homeassistant
Requires:	python3-awesomeversion
Requires:	python3-bcrypt
Requires:	python3-certifi
Requires:	python3-ciso8601
Requires:	python3-httpx
Requires:	python3-home-assistant-bluetooth
Requires:	python3-ifaddr
Requires:	python3-jinja2
Requires:	python3-lru-dict
Requires:	python3-PyJWT
Requires:	python3-cryptography
Requires:	python3-pyOpenSSL
Requires:	python3-orjson
Requires:	python3-pip
Requires:	python3-slugify
Requires:	python3-pyyaml
Requires:	python3-requests
Requires:	python3-typing-extensions
Requires:	python3-voluptuous
Requires:	python3-voluptuous-serialize
Requires:	python3-yarl

%description
Open source home automation that puts local control and privacy first.
Based on  https://home-assistant.io

%package -n python3-ais-dom
Summary:	Open-source home automation platform running on Python 3.
Provides:	python-ais-dom
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ais-dom
Open source home automation that puts local control and privacy first.
Based on  https://home-assistant.io

%package help
Summary:	Development documents and examples for ais-dom
Provides:	python3-ais-dom-doc
%description help
Open source home automation that puts local control and privacy first.
Based on  https://home-assistant.io

%prep
%autosetup -n ais-dom-2023.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ais-dom -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.3.2-1
- Package Spec generated